Actualizar 1.1.7 a 1.1.8

Estado
Cerrado para nuevas respuestas

Xarlie

Super Moderador
Miembro del equipo
¿Podrías poner el error exacto que te sale?
Es que no se si se refiere a permisos porque no tienes permisos desde tu proveedor para hacer conexiones externas o permisos de carpetas/ficheros...
 

Antonio

Nuevo usuario
que no tengo suficiente permiso para conectarme, siendo que he puesto los permisos a las carpetas pero ya no se que hacer, por mi me quedaria con la 1.1.7. pero me recomiendan pasarme a la nueva.
yo no me quedaria ni con la 1.1.7 ni con la 1.1.8.

...ver si tenemos una versión en condiciones que funcionen las cosas porque desde la 1.1.6 cada vez veo mas bugs aparte de los casi 400 que han solucionado :desentendido:.

No se quien lo dijo o donde lo ví por el foro, pero ojalá que saquen una versión estable para finales de año o principios del siguiente.

Además les daría el consejo de testearla bien antes de sacarla,porque lo que son las actualizaciones dejan mucho que desear. Mas bien desactualizan, porque la versión que tenía antes de la 1.1.6 me funcionaban unas cosas que ahora con la 1.1.8 no funcionan. En fin.... que estoy liado con algunos fallos y me entra la depre...

Y ademas alucino, algunas veces se arreglan las cosas por si solas oye.. como te lo cuento.

bueno que si sigo así va a parecer un blog
 

Xarlie

Super Moderador
Miembro del equipo
Lo dije yo :D

El problema de magento no son las comprobaciones sino el motor y los plugins que utiliza. Hay que tener en cuenta que se utiliza un motor diferente a xcart o osC... en estos el código php es puro y duro, utilizando oop pero muy diferente a magento.
Además, magento se apoya en muchas estructura de tal forma que es muy versátil y con una curva de escalabilidad increible para estar programado en php. Además de utilizar librerías de terceros y mucho javascript/AJAX.
Todo esto hace que en sistemas LAMP sea muy inestable puesto que directamente se está tocando el core del script y librerías fundamentales para que funcione cualquier pequeña cosa... por lo tanto debemos olvidarnos de realizar actualizaciones a la ligera como podriamos hacer con otros scripts.

Hay que pensar una cosa... un programa para gestionar tiendas requiere de tantas opciones y tantas historias para que nos valga a todos que plantear su desarrollo es ya una locura de por sí.
 

kakkonen

Nuevo usuario
me dice que no tengo suficiente permiso en las carpetas, tengo mi propio servidor linux y jamas he tenido este problema, mew gustaria instalarle unas aplicaciones a mi mgnt pero no me puedo conectar a connect, creo que dejare la version que tengo hasta la 1.2.0
 

Xarlie

Super Moderador
Miembro del equipo
Necesitas darle permisos a todo.
Si tienes acceso a tu servidor vía shell, te colocas en el raíz de tu página web y pones:

Con eso le das todos los permisos y si te sigue dando errores ya sabemos que no es por falta de permisos :)
 

kakkonen

Nuevo usuario
hola Xarlie, mira ya le di los permisos en Shell pero me siguew dando este error:

Error: Please check for sufficient write file permissions

Your Magento folder does not have sufficient write permissions, which this web based downloader requires.

If you wish to proceed downloading Magento packages online, please set all Magento folders to have writable permission for the web server user (example: apache) and press the "Refresh" button to try again.
ahor como estaban los permisos antes de ponerles 777? ya que me quedara inseguro el root
 

Xarlie

Super Moderador
Miembro del equipo
Eso es seguramente porque está intentando escribir en el directorio raíz de la web.
Prueba a darle también permisos.

Los permisos originales serían 755.

Lectura+Escritura+Ejecución: 7 (dueño)
Lectura+Ejecución: 5 (grupo)
Lectura+Ejecución: 5 (otros)

wrx o lo que es lo mismo: 4 + 2 + 1

Básicamente tu apache seguramente este corriendo bajo el usuario apache o cualquier otro usuario y por lo tanto no tiene permisos.
No es problemático siempre y cuando tu directorio de usuario (si es alojamiento compartido) tenga sus propios permisos.
Espero que te sirva de ayuda.
 

kakkonen

Nuevo usuario
hola, mira, hable con mi tecnico ya que hospedo a muchos sitios y jamas habia tenido problemas, ya una vez lo instale y me fallaron desde su instalacion las reglas de los productos, nuevamente instale y me fallo el admin y la tercera vezpuede ser que me haya fallado el conect, pero bueno he reseteado todo y estoy subiendo la version 1.8 y me quedare con esta hasta que salga la 2.0 porque no se me hace gracioso estar cada vez actualizando y ojala que mi respaldo funcione, porque este lunes que viene necesito ya tener todo montado.

gracias y si alguien sabe como solucionar esto que quizas a muchos les pase, se agradeceria ponerlo aqui ya que esta abierto
 
Estado
Cerrado para nuevas respuestas
Arriba