Añadir un bloque estatico

radge

Nuevo usuario
Buenas , acabo de actualizar a la 1.1.8 y lo tengo tal cual con el template sin modificar.

En la página estática HOME tengo la siguiente información , pero no me muestra , segun esto me tendria que mostrar los ultimos productos añadidos , y si he visitado alguno como he hecho yo , tambien , pero no lo hace y no entiendo el porque.

PHP:
<!--<reference name="content">
<block type="catalog/product_new" name="home.catalog.product.new" alias="product_new" template="catalog/product/new.phtml" after="cms_page"><action method="addPriceBlockType"><type>bundle</type><block>bundle/catalog_product_price</block><template>bundle/catalog/product/price.phtml</template></action></block>
<block type="reports/product_viewed" name="home.reports.product.viewed" alias="product_viewed" template="reports/home_product_viewed.phtml" after="product_new"><action method="addPriceBlockType"><type>bundle</type><block>bundle/catalog_product_price</block><template>bundle/catalog/product/price.phtml</template></action></block>
<block type="reports/product_compared" name="home.reports.product.compared" template="reports/home_product_compared.phtml" after="product_viewed"><action method="addPriceBlockType"><type>bundle</type><block>bundle/catalog_product_price</block><template>bundle/catalog/product/price.phtml</template></action></block>
</reference><reference name="right">
<action method="unsetChild"><alias>right.reports.product.viewed</alias></action>
<action method="unsetChild"><alias>right.reports.product.compared</alias></action>
</reference>-->
salu2 radge :ok:
 

radge

Nuevo usuario
Perdona copié mal.. cada vez entiendo menos esto...

Tengo este codigo en el HOME con una pagina a 3 columnas

Insertar CODE, HTML o PHP:
<reference name="content">
<block type="catalog/product_new" name="home.catalog.product.new" alias="product_new" template="catalog/product/new.phtml" after="cms_page"><action method="addPriceBlockType"><type>bundle</type><block>bundle/catalog_product_price</block><template>bundle/catalog/product/price.phtml</template></action></block>
<block type="reports/product_viewed" name="home.reports.product.viewed" alias="product_viewed" template="reports/home_product_viewed.phtml" after="product_new"><action method="addPriceBlockType"><type>bundle</type><block>bundle/catalog_product_price</block><template>bundle/catalog/product/price.phtml</template></action></block>
</reference>

<reference name="left">
<block type="cms/block" block_id="infocontacto"></block>
</reference>
Esto me tendria que montar en el content (en el medio) los ultimos productos vistos y los ultimos añadidos , y en la barar de la izquierda el bloque infocontacto , pues no... me muestra lo siguiente

En el content los ultimos vistos (los ultimos añadidos NO!) , en la izquierda me muestra el boletin de noticias y en la derecha los productos vistos recientemente y Mi carrito.

Tengo la cache deshabilitada y no entiendo nada de nada ;(

Aki lo podeis ver http://www.teacolors.es
 
Última edición:

cgfc

Nuevo usuario
Buenas , voy al panel de administracion ==> CMS ==> Bloques estaticos.

Alli creo y habilito un bloque estatico que muestra texto plano.



Entonces voy a CMS ---> Gestionar las paginas y en el HOME añado esto

Y en el menu izquierdo no me sale este bloque que estoy haciendo mal ?

He seguido esta guia http://www.magentocommerce.com/knowledge-base/entry/how-do-i-create-and-edit-static-blocks


<reference name="left">
<block type="cms/block" name="informacion_contacto" alias="product_homepage" template="cms/content.phtml"/>
</reference>


salu2 radge
yo lo uso de ésta forma y funciona bien

{{block type="cms/block" block_id="id-del-bloque"}}
 

raynexus

Nuevo usuario
Hola,

No quise abrir otro tema ya que este se relaciona bastante con lo que me esta sucediendo.

Tengo un bloque estatico el cual es una galeria de imagenes que rotan hecho en javascript. Quiero colocar ese bloque estático despues del encabezado (header) y antes del contenido de mi home (page), pero por mas que lo intento no aparece... :niidea:

la info que tengo en mi bloque estatico es la siguiente
Insertar CODE, HTML o PHP:
<div id="slider">
<ul>
<li><a href="www.misitio.com"><img src="{{skin url=slider/images/01.jpg}}" alt="Titulo 1" /></a></li>
<li><a href="www.misitio.com"><img src="{{skin url=slider/images/02.jpg}}" alt="Titulo 2" /></a></li>
<li><a href="www.misitio.com"><img src="{{skin url=slider/images/03.jpg}}" alt="Titulo 3" /></a></li>
<li><a href="www.misitio.com"><img src="{{skin url=slider/images/04.jpg}}" alt="Titulo 4" /></a></li>
<li><a href="www.misitio.com"><img src="{{skin url=slider/images/05.jpg}}" alt="Titulo 5" /></a></li>
</ul>
</div>
las imagenes, los css, los js se encuentran en un directorio llamado slider dentro de los skin de mi tema.

De hecho, en "Gestionar páginas" dentro de mi Home page coloque {{block type="cms/block" block_id="my_id""}} y funciona perfecto. Pero como el diseño de mi pagina es "2 columns with right bar" me aparece solo en la segunda columna.

Mi intencion es hacer que aparezca luego del header y antes del contenido de mi pagina pero no aparece, que debo hacer para que aparezca???

Saludos!
 

raynexus

Nuevo usuario
Gracias Xarlie,

Me explico un poco mejor.

Tengo un bloque estático llamado slider, y aparece de la siguiente forma en mi pagina:



Lo que quiero es que aparezca en la parte indicada en la imagen, pero no hallo como hacerlo.

Si alguien sabe como hacerlo por favor

Saludos!
 

Adjuntos

Xarlie

Super Moderador
Miembro del equipo
Claro pero si tu colocas el código dentro del CMS de Home lo tendrás en esa posicion y tu necesitas colocarlo dentro de tu plantilla en el fichero header.phtml
 

raynexus

Nuevo usuario
@Xarlie

Muchas gracias, ya hice la prueba colocando el bloque al final de la plantilla header.phtml, es justo el lugar donde queria que estuviera la galeria js. De nuevo gracias!

Saludos :hola::ok:
 

andkim1011

Nuevo usuario
Buenas tardes.

Tengo un problema con CMS, soy nueva en magento y muy bien no le entiendo, mi pagina en el menu cuenta con una imagen abajo de las subcategorias que se crearon; lo poco o mucho que le he visto al momento de crear el bloque ingreso este texto que es el que viene en los demas <p><img src="{{media url="wysiwyg/banner-fitness.jpg"}}" alt="Secci&oacute;n Ropa & Accesorios" /></p>

Despues viene otro bloque pero con esta informacion. <p><a href="{{store url="5-minute-shaper.html"}}"><img src="{{media url="menu/cat-fitness.jpg"}}" alt="Fitness" /></a></p>

Pero el menu no me aparace con la imagen, buscando informacion indica que en unos archivos hay que agregar informacion, esa informacion esta en los archivos que he encontrado. Nose si alguien me pueda apoyar.
 

Larry

Miembro
Esa imagen por lo que veo se ha introducido con Wysiwyg desde el CMS. Prueba a subirla y colocarla de nuevo.

Saludos.
 

andkim1011

Nuevo usuario
Buenas tardes Larry.

Ya quedo completo, y si tenias razon tenia que agregar la imagen a Wysiwyg, pero bien no entiendo para que sirve esa imagen. Pero ya funciono como yo deseaba. Saludos
 
Arriba