blank theme y otros fallos.

adelgado

Nuevo usuario
muy buenas a todos, acabo de instalar magento 1.1.8 y ahora quiero instalar blank theme para crear un tema propio.

me voy a magento connect manager y tras coger la key de blank theme, que si no me equivoco es:

magento-core/Interface_Frontend_Default_Blank

Se me han instalado los siguiente módulos de forma automática:


Lib_Google_Checkout 1.1.1 (stable) Google Checkout Library
Lib_Js_Calendar 1.1.7 (stable) Javascript Calendar for Magento
Lib_Js_Mage 1.1.3 (stable) Javascript Libraries for Magento
Lib_Js_Prototype 1.1.3 (stable) Prototype and Scriptaculous Javascript Libraries for Magento
Lib_Varien 1.1.3 (stable) Varien Library
Lib_ZF 1.1.1 (stable) Zend Framework
Lib_ZF_Locale 1.1.1 (stable) Zend Framework Locale

y cuando pulso en check for updates obtengo esto:

Exception caught:

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/bodas/public_html/downloader/pearlib/php/PEAR/REST/10.php on line 671

Backtrace:

#0 /home/bodas/public_html/downloader/pearlib/php/PEAR/REST/10.php(671): mageCoreErrorHandler(2, 'in_array() [listLatestUpgrades('stable', false)
#2 /home/bodas/public_html/downloader/pearlib/php/PEAR/Command/Common.php(285): PEAR_Command_Remote->doListUpgrades('http://connect....', 'stable', Array, 'connect.magento...', Object(Maged_Pear_Registry))
#3 /home/bodas/public_html/downloader/Maged/Pear.php(234): PEAR_Command_Common->run('list-upgrades', Array, Array)
#4 /home/bodas/public_html/downloader/Maged/Model/Pear.php(100): Maged_Pear->run('list-upgrades', Array, Array)
#5 /home/bodas/public_html/downloader/template/pear/packages.phtml(49): Maged_Model_Pear->getAllPackages('list-upgrades', Array)
#6 /home/bodas/public_html/downloader/Maged/View.php(59): include('/home/bodas/pub...')
#7 /home/bodas/public_html/downloader/Maged/Controller.php(113): Maged_View->template()
#8 /home/bodas/public_html/downloader/Maged/Controller.php(350): Maged_Controller->pearPackagesAction('pear/packages.p...')
#9 /home/bodas/public_html/downloader/Maged/Controller.php(170): Maged_Controller->dispatch()
#10 /home/bodas/public_html/downloader/index.php(35): Maged_Controller::run()
#11 {main}

y no se como corregirlo.


y si le doy a instalar el blank theme obtengo el siguiente resultado:

magento-core/Interface_Frontend_Default_Blank requires package "magento-core/Mage_Core_Modules" (version >= 1.1.8, version <= 1.2, excluded versions: 1.2), installed version is
Install Errors
No valid packages found
PEAR ERROR: install failed


¿Que hago? no se por donde seguir.
 
Última edición:

Xarlie

Super Moderador
Miembro del equipo
Pues intenta esto:

En el directorio downloader tendrás la carpeta con el blank theme, te guardas esta carpeta en un sitio seguro.
Borra todo
Reinstala la versión 1.1.8
Copias de la anterior carpeta del blank theme lo de app/design/frontend/default/blank/... y /skin/frontend/default/blank

Y luego lo activas en la configuración y ya está.
 

jogide

Nuevo usuario
Hola !

Voy a empezar a pelearme con el aspecto.

Lo suyo por lo que veo és instalar un blank y modificarlo.... algún tutorial o hilo para empezar de 0 ?

Un saludo !
 

Xarlie

Super Moderador
Miembro del equipo
@jogide, no mezcles temas en los hilos :)
En respuesta a tu pregunta lo mejor es empezar con el blank, que es fácil de modificar.

@adelgado, damos por cerrado el tema,pues :)
 

jogide

Nuevo usuario
@jogide, no mezcles temas en los hilos :)
En respuesta a tu pregunta lo mejor es empezar con el blank, que es fácil de modificar.
Lo sé, lo siento. Pero es que me aguanto tanto como puedo; me da mal rollo empezar infinidad de hilos para preguntar cosas, preferia hacer una incursión rápida por si alguien me puede direccionar a algún tutorial.
Me resulta muy difícil encontrar info con los buscadores :triste:
Me esforzaré más:ok:
 
Arriba