Cambiar a español el mensaje de información de pago

Tema en 'Soporte General' iniciado por bricosanz, 3/3/15.

  1. bricosanz

    bricosanz Nuevo usuario

    9
    0
    1
    Hola, tengo instalado magento 1.8 con la extensión "Magento-BankPayment-master" para hacer pagos con transferencia a banco. Al momento de hacer una compra en la información de pago, en "Transferencia Bancaria" me muestra un mensaje "More information on this paymentmethod can be found here."
    Lo he cambiado al español en: app\locale\es_ES y en_US, pero sigue igual, se muestra en inglés.

    Lo mismo me pasa con el método "Cash on delivery", me muestra el mensaje "You will be charged an extra fee of € 0,00", este ultimo mensaje no lo encuentro en los CSV.

    ¿Como puedo hacer para cambiar estos textos al español?
     
  2.  
    Comunidad Magento orgullosamente patrocinada por el hosting y vps magento de FactoriaDigital.com.
  3. KiwiWeb

    KiwiWeb Miembro

    278
    14
    18
    Buenas bricosanz,
    Puede que sea una línea de texto que se pueda modificar en algúna configuración del módulo, yo miraría si hay algún menu que haya instalado en Sistema->configuración(¿->metodos de pago?) y ahí miraría si aparece ese texto para cambiarlo .
    Sino en sistema->configuración->desarrollador eliges la vista de la tienda poniendolo en la vista de idioma y en el menu de "linea interna de traducción, lo ponemos en "SI", ahora si vamos al front cada palabra o frase traducible debería estar rodeada de un cuadrado punteado rojo el cual, si pones el raton encima, debería aparecer un librito, aquí podemos cambiar el idioma, pero PRIMERO SELECCIONA EL CHECKBOX, para que sólo se aplique a esa vista.

    Espero que te sirva de ayuda, siento no poder poner pantallazos, pero me cambie a linux y echo de menos el paint, un saludo
     
  4. Larry

    Larry Miembro

    769
    18
    18
    No vas a poder cambiarlo desde csv ni desde Translate Inline... yo lo he probado y al final mirando el módulo la única forma es desde fichero. El problema es que el texto que se muestra no pasa por la funcion que revisa los csv de tradución. Para que entiendas un poco más, un texto que se traduce por csv se ve así :

    <?php echo $this->__('Text to translate'); ?>

    Mientras que el módulo esta hecho así:

    <?php echo 'You will be charged an extra fee of' ; ?>

    Por lo que hay que ho modificar el módulo para que te coja la traducción o hacerlo a mano.

    Saludos.
     
  5. bricosanz

    bricosanz Nuevo usuario

    9
    0
    1
    Hola Larry.

    Sabes donde se encuentra ese Fichero?
     
  6. KiwiWeb

    KiwiWeb Miembro

    278
    14
    18
    Para ver donde esta el fichero ve a Sistema->configuración->desarrollador, en el desplegable arriba a la derecha en "Alcance de la configuración actual" ponlo en la vista de idioma o de tienda, entonces en el menu "Depurar" tendrán que aparecer tres opciones, ponlas a "Sí", recarga la página y verás como cada sección de la página tiene un recuadro rojo y en la esquina superior izquierda una ruta de donde esta el archivo que lo pinta. Desactiva las tres opciones anteriores, sin miedo, pues no perderás la vista de recuadros hasta que no recargues, pero si la página esta publicada mejor que los clientes no lo vean.
    Ahora con la ruta sólo tienes que descargartelo por FTP y cambiarlo.

    Espero que te sirva, un saludo.
     
  7. bricosanz

    bricosanz Nuevo usuario

    9
    0
    1
    Ok y Gracias KiwiWeb.
     
Cargando...

Compartir esta página

Cargando...