Cambio de idioma en la instalación y No funciona Menu Backend

vertical

Nuevo usuario
Hola,

He estado probando Magento en local y este funciona correctamente. El proceso de instalación que sigo es el siguiente:
1- Descomprimo archivos de Magento.
2- Descomprimo archivos del lenguaje español (98% traducido).
3- Inicio la instalación (en español a partir de la selección del Idioma/Región).

Siguiendo estos sencillos pasos la instalación va a la parfección y luego el funcionamiento de Magento es el correcto.

Ahora he decidido instalarlo en el hosting que tengo contratado. Los pasos que realizo son los siguientes:
1- Subo un archivo .zip que contiene los archivos de Magento + Idioma Español.
2- Mediante CPanel (aplicación de gestión del Hosting) descomprimo el .zip.
3. Inicio la instalación (en español a partir de la selección del Idioma/Región).

3.1 - En el paso de configuración me sale la siguiente advertencia la cual soluciono sin problemas:
La carpeta "/home/skatelon/public_html/app/etc" debe tener permisos de escritura
La carpeta "/home/skatelon/public_html/var" debe tener permisos de escritura
La carpeta "/home/skatelon/public_html/media" debe tener permisos de escritura

3.2 - A continuación se muestra la pantalla de configuración para introducir los datos de la BBDD. Aquí el idioma ha cambiado a Inglés y continua así hasta el final de la instalación. Esto en local no pasaba.
3.3 - Creo el Usuario Administrador (también en inglés).
3.4 - Se finaliza la instalación correctamente.

El siguiente paso es ir al Backend. Este está en Inglés.
Pero lo más sorprendente de todo es que no funciona el Backend. Los items del menu no se delplegan, por lo que es imposible hacer nada. Simplemente se pude ver la pantalla principal "Dashboard".

Alguien sabe a que se puede deber esto?

Saludos y gracias por adelantado.
 

vertical

Nuevo usuario
Para simplificar, he instalado Magento sin la traducción a español, realizando la instalación en inglés.

El problema continua, el Backend no funciona.
 

OSdave

Super Moderador
Miembro del equipo
hola Vertical,
De lo que leo en los foros US hay 3 (por lo menos) opciones para que no funcione el menu del backend:
  1. no es la ultima version de magento (1.0.19870): en versiones anteriores habia un bug con el menu del admin que fue coregido. Si no tienes esta version, bajatela
  2. no se han subido todos los archivos, o algunos son incompletos: a mi me paso varias veces. Pero si dices que has extraido el zip directamente en el servidor, no debe ser tu caso
  3. poner los permisos de js/proxy.php a 644
Espero que te ayuda
salu2
 

vertical

Nuevo usuario
Hola OSdave,

Gracias por tu rápida respuesta.

1.- Si que se trata de la última versión, la magento-1.0.19870.4
2.- No creo que la extracción en el servidor falle. Lo he realizado varias veces.
3.- He puesto los permisos de js/proxy.php de 664 a 644 y sigue sin funcionar.


Saludos.
 

OSdave

Super Moderador
Miembro del equipo

vertical

Nuevo usuario
Hola,

He estado realizando varias pruebas a partir de lo que me ha dicho OSdave y lo que he encontrado en este thread http://www.magentocommerce.com/boards/viewthread/4679/P30/#t17628.

1.- Poniendo los permisos de js/proxy.php a 777 tampoco funciona.
2.- No he podido instalar la extensión:
Insertar CODE, HTML o PHP:
Failed to download magento-community/Fooman_FixHeadPhp within preferred state "stable", latest release is version 0.1.1, stability "alpha", use "channel://connect.magentocommerce.com/community/Fooman_FixHeadPhp-0.1.1" to install
Cannot initialize 'channel://connect.magentocommerce.com/community/Fooman_FixHeadPhp', invalid or missing package file
Install Errors
Package "channel://connect.magentocommerce.com/community/Fooman_FixHeadPhp" is not valid
PEAR ERROR: install failed
3.- Por el foro en inglés parece ser que poniendo los permisos a 755 suele ser suficiente. Pero en el caso de mi hosting parece ser que es necesario ponerlos a 777. Deberia poner los permisos de todas las carpetas de Magento a 777?

4.- El tema que comentaba de que a media instalación cambiaba de idioma español a inglés lo he solucionado dándole permisos 777 a todos los directorios que se encuentran dentro de ./js. De todos modos ahora estoy centrado en instalar la versión en inglés a pelo, hasta que se solucione el tema del menu.

Voy a seguir probando a ver si encuentro con la solución.

Saludos.
 
Última edición:

OSdave

Super Moderador
Miembro del equipo
por lo de la extensión de lo que veo lo tienes definido como que solo acepte las extensiones con estabilidad stable: esta esta en alfa de momento. Puedes cambiar el estado permitido en la pestaña Settings cuando estas dentro del connect.
 

vertical

Nuevo usuario
Finalmente funciona

Voy a describir los pasos realizados:

Versión de Magento: magento-1.0.19870.4.zip
Lenguaje: es_ES_default_full_package.zip al 99.26%


  • Subir los archivos de Magento al servidor
El sistema de archivos de Magento es realmente grande, por lo que si lo subimos por FTP uno a uno se tardará mucho.
Es recomendable, siempre que nuestro hosting lo permita, subir los archivos de Magento comprimidos en un archivo y descomprimirlos una vez este se encuentre en el servidor.​

  • Cambiar los permisos de los directorios y los ficheros
Hay que poner los permisos de los directorios a 777.
Hay que ponser los permisos de los ficheros a 666.

Al igual que en el punto anterios, si realizamos este proceso mediante algún programa FTP, este tardará mucho debido al extenso sistema de archivos de Magento.
Por este motivo se recomienda, siempre que el hosting lo permita, realizar este proceso vía SSH:

- Cambiar permisos directorios a 777: find ./ -type d -exec chmod 777 {} \;
- Cambiar permisos ficheros a 666: find ./ -type f -exec chmod 666 {} \;​

  • Iniciar la instalación vía web
Iniciar la instalación web. Seguir todos los pasos hasta el final.
Una vez finalizada la instalación NO ir ni al Frontend ni al Backend.​

  • Instalar extensión "Fooman Fix for Non-Working Admin Menus"
Para realizar este paso:
-Ir a miDominio.com/downloader/index.php.
-Introducir nombre de usuario del administrador y contraseña.
-Ir a la pestaña de Settings y en la opción de Preferred State poner Alpha.
-Volver a la pestaña de extensions, pegar la extension key y darle al botón de instalar.
**La extension key se obtiene de Fooman Fix for Non-Working Admin Menus

Una vez instalada la extensión ya se puede ir al Backend. El menú deberia funcioar.

*Estos son los pasos que he seguido y ahora tengo Magento instalado en español (99.26%) y el menú del Backend funciona a la perfección.

**El tema de cambiar los permisos de todos los directorios y ficheros no se si es del todo correcto. Alguna sugerencia al respecto?

Saludos.
 

DAJHE

Nuevo usuario
he provado cambiar permisos de archovos i nda he intentado instalar la extencion Fooman... pero no encuentro la extencion key en la web otra cosa esa solucion aplicara tambien a magento 1.5.1.0 ..??
 

Mónica

Nuevo usuario
Buenos días, a mi me pasa lo mismo que a Vertical solo que con la versión 1.6.2.0. No van los menús desplegables del admin. He seguido todos los pasos de una instalación correcta, puesto los permisos a 777 y sigue sin funcionar.
Alguien puede ayudarme??
Gracias
 
Arriba