Error al editar Clientes

Olafo

Nuevo usuario
Hola tengo instalada la versión 1.3.2.1
Alguien sabe porque pasa esto?

en Gestionar Clientes dentro de la sección de Clientes, al tratar de editar uno, recibo el siguiente error:

Warning: include(Mage/Customerprofile/Model/Gendertype.php) [function.include]: failed to open stream: No such file or directory in /home6/mdhogarc/public_html/lib/Varien/Autoload.php on line 93
Trace:
#0 /home6/mdhogarc/public_html/lib/Varien/Autoload.php(93): mageCoreErrorHandler(2, 'include(Mage/Cu...', '/home6/mdhogarc...', 93, Array)
#1 /home6/mdhogarc/public_html/lib/Varien/Autoload.php(93): Varien_Autoload::autoload()
#2 [internal function]: Varien_Autoload->autoload('Mage_Customerpr...')
#3 /home6/mdhogarc/public_html/app/code/core/Mage/Core/Model/Config.php(1084): spl_autoload_call('Mage_Customerpr...')
#4 /home6/mdhogarc/public_html/app/Mage.php(319): Mage_Core_Model_Config->getModelInstance('Mage_Customerpr...')
#5 /home6/mdhogarc/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(367): Mage::getModel('customerprofile...',
 

gdecaceres

Miembro
haz una cosa busca ese fichero en tu site a ver si lo encuentras en alguna otra ruta.
yo en la 1.3.1 no lo tengo por ningun lado.
voy a descargarmelo y a ver si te puedo decir algo al final de la tarde que estoy con una import de erp de la empresa para la facturacion.

Un saludo y espero se te solocione
 
Upvote 0

Olafo

Nuevo usuario
No conseguí ese archivo en ningún lado, tampoco lo conseguí en el servidor de desarrollo, pero ahí si trabaja bien.
 
Upvote 0

Olafo

Nuevo usuario
Ahora estar peor
No puedo conectarme al Magento Connect
recibo esta grocería:

Alguien sabe??? no consigo nada en los foros en ingles ???

Fatal error: Uncaught exception 'Zend_Db_Adapter_Exception' with message 'pdo_mysql extension is not installed' in /home6/mdhogarc/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php:200 Stack trace: #0 /home6/mdhogarc/public_html/lib/Zend/Db/Adapter/Abstract.php(441): Varien_Db_Adapter_Pdo_Mysql->_connect() #1 /home6/mdhogarc/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(230): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array) #2 /home6/mdhogarc/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(281): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array) #3 /home6/mdhogarc/public_html/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8') #4 /home6/mdhogarc/public_html/app/code/core/Mage/Core/Model/Resource.php(87): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element)) #5 /home6/mdhogarc/public_html/app/code/core/Mage/Core/Model/Mysql4/Session.php(68): Mage_Core_Model_Resource->getConnection('core_read') # in /home6/mdhogarc/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php on line 200
 
Upvote 0

Olafo

Nuevo usuario
Gracias Xarlie :ok:, eso era
Aunque todavía no se como se quito.

Pero aun sigue el problema al tratar de editar un cliente :niidea:

Alguna pista ?
 
Upvote 0

Olafo

Nuevo usuario
Hola tengo instalada la versión 1.3.2.1
Alguien sabe porque pasa esto?:sorprendido:

El tratar de editar un cliente me sale este error:
Lo he probado en desarrollo y funciona bien, que tengo que volver a subir para arreglar esto :niidea:

Warning: include(Mage/Customerprofile/Model/Gendertype.php) [function.include]: failed to open stream: No such file or directory in /home6/mdhogarc/public_html/lib/Varien/Autoload.php on line 93
Trace:
#0 /home6/mdhogarc/public_html/lib/Varien/Autoload.php(93): mageCoreErrorHandler(2, 'include(Mage/Cu...', '/home6/mdhogarc...', 93, Array)
#1 /home6/mdhogarc/public_html/lib/Varien/Autoload.php(93): Varien_Autoload::autoload()
#2 [internal function]: Varien_Autoload->autoload('Mage_Customerpr...')
#3 /home6/mdhogarc/public_html/app/code/core/Mage/Core/Model/Config.php(1084): spl_autoload_call('Mage_Customerpr...')
#4 /home6/mdhogarc/public_html/app/Mage.php(319): Mage_Core_Model_Config->getModelInstance('Mage_Customerpr...')
#5 /home6/mdhogarc/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(367): Mage::getModel('customerprofile...',
 
Upvote 0

Xarlie

Super Moderador
Miembro del equipo
Revisa el fichero que te pide incluir en esta línea:
/home6/mdhogarc/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(367)

Comprueba que existe
 
Upvote 0

Xarlie

Super Moderador
Miembro del equipo
No entiendo que puede pasar... si existe el fichero porque te dice que no lo encuentra... Quizás en el log de errores de PHP tengas algún dato más que pueda ayudarte, pero no se...
 
Upvote 0

Olafo

Nuevo usuario
OK. Voy a revisar y te aviso.
No entiendo todo esta igual que el server de desarrollo, ahí funciona bien.
pienso que pudo haber sido alguna extensión que se instalo y luego se desinstalo. pero no recuerdo cual fue esa extensión.
Voy a revisar el log de errores...
 
Upvote 0
Arriba