Error al entrar a página de administrador

Middrel

Nuevo usuario
Hola, buenas tardes. Un saludo a todos!

Me encargaron subir una copia de un sitio realizado en Magento a un hosting nuevo. Después de muchos problemas con versiones de PHP, bases de datos no enlazadas, etc., pude al fin hacer que "funcione". Sin embargo, he tratado de entrar al panel de administración de Magento y me muestra un error, el cuál es el siguiente:

Esta página no funciona
La página mydominio no puede procesar esta solicitud ahora.

HTTP ERROR 500

No soy experto en Magento, la verdad es la primera vez que lo estoy utilizando y según me comentan debo entrar con la siguiente liga:

https://mydominio.com/index.php/adminpart/index/index/key/xxxxxxxxxxxxxxxxxxxx/

Bueno, al intentar eso marca el error antes mencionado.

Intenté entrar como https://mydominio.com/index.php/admin/ pero me sale el error 404 de página no encontrada.

¿Saben si me falta configurar algo aún o es un error de versiones o algo pueda solucionar esto? De antemano, les agradezco por sus comentarios.

Saludos y buena tarde!
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Middrel,

Un error 500 significa que algo está funcionando mal en el servidor o en el código, pero el servidor no es capaz de concretarte más. Normalmente puede ser por varios motivos, entre ellos, los mas comunes:
También puedes revisar el archivo error_log que dependiendo del hosting estará en un sitio u otro. Normalmente estará en la raíz del Magento o sino en /var/log/apache2/error_log para Apache o en /var/log/nginx/error_log para Nginx.
En ese archivo se registran los errores 500, especificando mejor lo que ha ido mal durante su ejecución.

Si tampoco tuvieras éxito, revisa los logs de Magento, aunque al no conseguirse ejecutar, seguramente no generen errores: /var/log/exception.log, /var/log/system.log

Un saludo.
 

Middrel

Nuevo usuario
Toni, gracias por tu respuesta.

Verificando lo que me indicas, noté lo siguiente:

Lo tengo configurado en PHP 5.6, si intento subir a 7+ ya no me deja ingresar al sitio.
Hasta donde sé, no han hecho modificaciones al código, solo habían utilizado el administrador para subir sus productos.

De las extensiones tenemos lo siguiente: https://ibb.co/0X2t1PT



safe_mode si está en off. pero memory_limit está en 128. https://ibb.co/rvSy7kT


Lo último que me muestra el log es lo siguiente:

Insertar CODE, HTML o PHP:
[10-Jul-2019 01:00:38 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[10-Jul-2019 16:29:26 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[10-Jul-2019 18:29:34 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[10-Jul-2019 19:42:43 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[10-Jul-2019 23:19:23 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[11-Jul-2019 02:49:31 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[11-Jul-2019 20:46:07 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[11-Jul-2019 21:00:43 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[11-Jul-2019 22:50:25 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[11-Jul-2019 22:51:02 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[11-Jul-2019 23:00:13 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[12-Jul-2019 07:56:03 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[12-Jul-2019 08:37:18 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[12-Jul-2019 11:38:45 UTC] PHP Fatal error:  Class 'Mage_Core_Block_Html_Calendar' not found in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 491
[12-Jul-2019 15:03:05 UTC] PHP Fatal error:  Uncaught Error: Function name must be a string in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php:555
Stack trace:
#0 /home/usuario/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(390): Mage_Core_Model_Layout->getOutput()
#1 /home/usuario/public_html/app/code/core/Mage/Cms/Helper/Page.php(137): Mage_Core_Controller_Varien_Action->renderLayout()
#2 /home/usuario/public_html/app/code/core/Mage/Cms/Helper/Page.php(52): Mage_Cms_Helper_Page->_renderPage(Object(Mage_Cms_IndexController), 'home')
#3 /home/usuario/public_html/app/code/core/Mage/Cms/controllers/IndexController.php(45): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), 'home')
#4 /home/usuario/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Cms_IndexController->indexAction()
#5 /home/usuario/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('index')
#6 /home/xxxxx in /home/usuario/public_html/app/code/core/Mage/Core/Model/Layout.php on line 555
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Comprueba sobretodo qué error se genera cuando intentas acceder al panel de administración, ya que parece que no todos los errores son de la misma ejecución, así sabrás exactamente cuál provoca el fallo.
Lo que es seguro es que esos errores están provocando tu error 500, por lo que tendrás que ir descartando errores, empezando por los más comunes como puedan ser el core de Magento modificado, por lo que tendrías que reinstalar uno para esa versión o verificando el código para cada una de las páginas afectadas.

Por otro lado, deberías aumentar el memory_limit, Magento 1 recomienda tenerlo al menos en 512MB:

Insertar CODE, HTML o PHP:
memory_limit no less than 256 MB (512 MB recommended)
Aparece en el enlace que te pasé anteriormente.

Un saludo.
 

Middrel

Nuevo usuario
Sí, ya solicite a mi cliente, que le solicite a su proveedor de hosting que modifique los parámetros necesarios de acuerdo a las especificaciones que me enviaste. Tengo que esperar un poco ya que no tengo el control para poder hacerlo :(

Una vez hechas las adecuaciones veré si el error persiste.

Saludos!
 

Middrel

Nuevo usuario
Después de muchos días, por fin pudimos modificar los parámetros. El servidor donde está alojado el sitio no cumplía con todos los requisitos así que se cambió a un servidor dedicado donde pude hacer modificaciones en el WHM directamente. Con esto ya comprobé que los requerimientos estén de acuerdo a lo que se necesita.

Sin embargo, aún no puedo entrar al administrador de Magento, estos son los errores que me muestra:

1. Si intentó entrar como dominio.com/admin/index.php:

WHOOPS, OUR BAD...
The page you requested was not found, and we have a fine guess why.
  • If you typed the URL directly, please make sure the spelling is correct.
  • If you clicked on a link to get here, the link is outdated.
2. Si intentó entrar por la siguiente liga: https://dominio.com/index.php/adminpart/index/index/key/xxxxxxxxxxxxxxxxxx/

Esta página no funciona
La página dominio.com no puede procesar esta solicitud ahora.

HTTP ERROR 500
En el log de hoy me muestra los siguientes errores:

HTML:
[29-Jul-2019 00:42:20 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 06:28:57 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 11:00:18 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 11:38:07 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 13:05:55 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 16:34:25 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 18:02:31 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[29-Jul-2019 18:09:46 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
Según estaba leyendo, hay que habilitar la extensión iconv de PHP, esto es lo que tengo en el PHP.ini

Insertar CODE, HTML o PHP:
[iconv]
;iconv.input_encoding = ISO-8859-1
;iconv.internal_encoding = ISO-8859-1
;iconv.output_encoding = ISO-8859-1
y que debo quitar ; de
extension=iconv.so

sin embargo, esa línea no la tengo en el archivo de PHP.ini

¿Alguna idea de que me falta para corregir esto?

Saludos cordiales.
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

En caso de no funcionarte el acceso sin añadir index.php delante de /rutaadmin, es porque posiblemente esté mal configurado Nginx, no dispongas de mod_rewrite activado para Apache o bien hayas borrado el archivo .htaccess de pub/static que se encarga de las redirecciones.
De ser el último caso, puedes rescatarlo del repositorio oficial de Magento, para la versión 2.3.2 por ejemplo, sería este: https://github.com/magento/magento2/blob/2.3.2/pub/static/.htaccess
Puedes navegar por los "tags" para obtener el de tu versión exacta.

Por otro lado, como bien comentas, parece que tampoco tienes activada la extensión iconv de PHP. Dependiendo de tu hosting, es posible que se deba añadir de otra forma a la habitual o que directamente estén las opciones de iconv pero en si, no esté instalada.
Lo recomendable, si tienes dudas, sería contactar con tu hosting y que te indiquen como instalarla, o que incluso la instalen ellos para la versión de PHP que tienes activa actualmente.

De ya estar instalada, deberían decirte la ruta donde encontrar iconv.so para que añadieras la línea que comentabas al php.ini. Lo habitual es que no haga falta ninguna ruta y sea tal cual la expusiste:

Insertar CODE, HTML o PHP:
extension=iconv.so
Como te decía, cada hosting lo trabaja diferente, así que podría ser que no necesites modificar el php.ini o bien se tenga que hacer de otra forma para que PHP detecte la nueva extensión.

Un saludo.
 

Middrel

Nuevo usuario
Hola Toni, gracias por responder!

Si está el archivo htaccess, al menos está, no sé si le hayan metido mano:

Insertar CODE, HTML o PHP:
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    php_value memory_limit 768M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

    php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter on all content
    ###SetOutputFilter DEFLATE
    # Insert filter on selected content types only
    #AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## uncomment next line to enable light API calls processing

#    RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

############################################
## rewrite API2 calls to api.php (by now it is REST only)

    RewriteRule ^api/rest api.php?type=rest [QSA,L]

############################################
## workaround for HTTP authorization
## in CGI environment

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## TRACE and TRACK HTTP methods disabled to prevent XSS attacks

    RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
    RewriteRule .* - [L,R=405]

############################################
## redirect for mobile user agents

    #RewriteCond %{REQUEST_URI} !^/mobiledirectoryhere/.*$
    #RewriteCond %{HTTP_USER_AGENT} "android|blackberry|ipad|iphone|ipod|iemobile|opera mobile|palmos|webos|googlebot-mobile" [NC]
    #RewriteRule ^(.*)$ /mobiledirectoryhere/ [L,R=302]

############################################
## always send 404 on missing files in these folders

    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    AddDefaultCharset Off
    #AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    Order allow,deny
    Allow from all

###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version

    <Files RELEASE_NOTES.txt>
        order allow,deny
        deny from all
    </Files>

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

# php -- BEGIN cPanel-generated handler, do not edit
# Configure el paquete “ea-php56” como el lenguaje de programación predeterminado “PHP”.
<IfModule mime_module>
  AddHandler application/x-httpd-ea-php56 .php .php5 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit
Con respecto al mod_rewrite. no estoy muy seguro aún. Estaba buscando en el WHM donde configurarlo (por que lo debo buscar yo, los del hosting que son GoDaddy dicen que esas configuraciones corren por parte del cliente O_O)
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Parece que está bien ese archivo, pero ante la duda puedes sustituirlo, respetando únicamente las últimas líneas que son las que añade cPanel.

Por lo que parece, te está poniendo la versión de PHP 5.6 que no soporta Magento 2. Deberías tener activa la versión 7.0 o superior dependiendo de la versión de Magento 2 que tengas, ya que para la 2.3 en adelante, solo están soportadas la versión 7.1.3 y 7.2

De cara a mod_rewrite, puedes verificarlo entrando desde WHM al EasyApache4 y personalizando el paquete activo entrarás a ver los módulos de Apache instalados o que puedas instalar, así como extensiones de PHP.
En el apartado de Apache Modules, filtra por rewrite y debería salirte para instalar. Una vez lo marcas, pasa al último paso "Revisar" y pulsa Aprovisionamiento.
Si no te apareciera el módulo, es posible que ya esté compilado a nivel de servidor y por tanto, ya lo tengas activado.

Si nada de esto te sirve, verifica los archivos de error del servidor así como los errores que se hayan podido generar en Magento. Las rutas suelen ser:
  • /var/log/apache2/error.log
  • <ruta de Magento>/var/log/exception.log
  • <ruta de Magento>/error_log (En ocasiones se genera un error_log dentro de la propia raíz de la cuenta, esto depende del hosting, por lo que puede que no tengas este archivo)

Un saludo.
 

Middrel

Nuevo usuario
Cambiando la versión de PHP a la 7.0, el PHP.ini me proporciona lo siguiente en la extensión iconv. Ya instalada la extensión en 5.6 y 7.0:

Insertar CODE, HTML o PHP:
[iconv]
; Use of this INI entry is deprecated, use global input_encoding instead.
; If empty, default_charset or input_encoding or iconv.input_encoding is used.
; The precedence is: default_charset < intput_encoding < iconv.input_encoding
iconv.input_encoding =

; Use of this INI entry is deprecated, use global internal_encoding instead.
; If empty, default_charset or internal_encoding or iconv.internal_encoding is used.
; The precedence is: default_charset < internal_encoding < iconv.internal_encoding
;iconv.internal_encoding =

; Use of this INI entry is deprecated, use global output_encoding instead.
; If empty, default_charset or output_encoding or iconv.output_encoding is used.
; The precedence is: default_charset < output_encoding < iconv.output_encoding
; To use an output encoding conversion, iconv's output handler must be set
; otherwise output encoding conversion cannot be performed.
;iconv.output_encoding =
Los logs de error:

<ruta de Magento>/error_log

Insertar CODE, HTML o PHP:
[30-Jul-2019 04:09:05 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[30-Jul-2019 04:09:17 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[30-Jul-2019 04:39:40 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 04:39:41 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 04:39:52 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 04:40:03 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 04:43:37 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
[30-Jul-2019 10:38:43 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 10:38:44 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 10:38:54 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 10:39:04 UTC] PHP Fatal error:  Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[30-Jul-2019 13:41:08 UTC] PHP Fatal error:  Call to undefined function iconv_substr() in /home/xxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Helper/String.php on line 103
<ruta de Magento>/var/log/exception.log
No hay información actual de errores. El último fue hace un mes.

No encontré el log del Apache :/

Por otro lado, como puedo saber que versión de Magento tengo? Mi cliente no recuerda, y en el cPanel, al parecer, dice que es la 1.9.0.1, si es así creo que está muuuuy atrasada.
https://ibb.co/qxSgnXD

Saludos!
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Me confundí pensando que era un Magento 2, según los errores se ve claramente que las rutas de los archivos son de un Magento 1.
Para ver la versión, puedes comprobarlo desde el panel de administración o mirando el archivo app/Mage.php, en la función getVersionInfo() donde verás la versión instalada.
Si es una 1.9.0 no es muy vieja, ya que la última es la 1.9.4, a la cual te recomiendo actualizar desde que puedas.

Vuelve entonces a activar PHP 5.6, ya que Magento 1.x no es compatible con PHP 7.0 o superiores hasta que no dispongas de una versión 1.9.2 o superior de Magento.
Asegúrate de tener instalada la extensión de iconv para PHP 5.6 desde EasyApache 4 en el WHM.

Si tras esto, no se generan fallos recientes, no te sabría decir donde mas mirar sin tener acceso.

Espero que des con ello,
Un saludo.
 

Middrel

Nuevo usuario
Hola Toni, no te preocupes :)

Ya realicé los cambios, ya está nuevamente como PHP 5.6, ya instalé la extensión y verifiqué que haya quedado instalada y activada, la única duda en este punto es como incluirla correctamente en el archivo PHP.ini, yo lo hice de esta manera:

Insertar CODE, HTML o PHP:
[iconv]
iconv.input_encoding = ISO-8859-1
iconv.internal_encoding = ISO-8859-1
iconv.output_encoding = ISO-8859-1
extension=iconv.so
como vi que aún no funcionaba, quite las comillas a las líneas iconv.input_encoding = ISO-8859-1, iconv.internal_encoding = ISO-8859-1, iconv.output_encoding = ISO-8859-1, pero aún así no funciona, me envía ahora estos errores:

Insertar CODE, HTML o PHP:
[31-Jul-2019 10:04:48 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function iconv_get_encoding() in /home/xxxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php:552
Stack trace:
#0 /home/xxxxxxxxxxxxxx/public_html/lib/Zend/Uri/Http.php(445): Zend_Validate_Hostname->isValid('www.midominio.co...')
#1 /home/xxxxxxxxxxxxxx/public_html/lib/Zend/Uri/Http.php(277): Zend_Uri_Http->validateHost()
#2 /home/xxxxxxxxxxxxxx/public_html/lib/Zend/Uri/Http.php(154): Zend_Uri_Http->valid()
#3 /home/xxxxxxxxxxxxxx/public_html/lib/Zend/Uri.php(143): Zend_Uri_Http->__construct('http', '//www.midominio....')
#4 /home/xxxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Model/Store.php(773): Zend_Uri::factory(Array)
#5 /home/xxxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(332): Mage_Core_Model_Store->isCurrentlySecure()
#6 /home/xxxxxxxxxxxxxx/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(161): Mage_Core_Controller_Varien_Front->_checkBaseUrl(Object(Mage_Core_Controller_Request_Http))
#7 /home/xxxxxxxxxxxxxx/public_html/app/code/core in /home/xxxxxxxxxxxxxx/public_html/lib/Zend/Validate/Hostname.php on line 552
[31-Jul-2019 14:26:10 UTC] PHP Notice:  Undefined index: HTTP_HOST in /home/xxxxxxxxxxxxxx/public_html/index.php on line 87
Antes de mostrar los errores y después de haber hecho los cambios, reinicie el servidor de Apache.

Saludos!
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Verifica entrando mediante SSH al servidor que realmente está cargada la extensión, debería salirte algo así:

Insertar CODE, HTML o PHP:
[root@server ~]# php -m | grep iconv
iconv
Si no tienes acceso SSH, como alternativa, crea un archivo accesible desde tu dominio que incluya:

Insertar CODE, HTML o PHP:
<?php phpinfo(); ?>
Accede a el y revisa el contenido, buscando por iconv, para comprobar que esté cargada.

Un saludo.
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Entonces no veo el motivo del porque no te funcionan las funciones de iconv. Lo único que se me ocurre es que intenten verificarlo desde GoDaddy, pero si dices que lo dejan directamente en tus manos, no creo que te den una solución.

Por mi parte no te se decir nada mas sin poder acceder a mirar directamente para tratar de averiguar el motivo.

A ver si a alguien mas por el foro se le ocurre que puede ser y te indica.

Un saludo.
 

Middrel

Nuevo usuario
Hola Toni, gracias de todas formas! :D

Apenas hoy me dice mi cliente: "ya nos había dicho nuestro webmaster anterior que el sitio venía con problemas desde hace tiempo... pero lo habíamos dejado pasar..." ¬¬

Imaginarás mi expresión de este lado del teléfono...

Saludos!! :D
 
Arriba