Error con css agrupados

Tema en 'Diseño' iniciado por manuel_gdb, 23/4/15.

Etiquetas:
  1. manuel_gdb

    manuel_gdb Nuevo usuario

    5
    0
    1
    Buenas a todos! Espero que este sea el hilo correcto para esta cuestión. He estado buscando por ahí algo relacionado pero no encuentro nada.

    Acabo de realizar una migración de mi tienda de un servidor a otro (sin modificaciones de ningún tipo) y estoy teniendo problemillas con los css. En la tienda antigua tenía habilitada la opción "merge css" para agrupar los css. Y funciona bien, todo correcto. Pero al pasar al nuevo servidor, si activo esta opción el css agrupado no se carga. Si "desagrupo" los css sí que funcionan bien. Pero si activo la opción, el css nuevo es como si no se encontrara. Si intento cargar la ruta donde se encuentra el css agrupado (media/css/nombredelcss.css) me devuelve un error 404. Pero el css se encuentra en esa ruta!

    He probado a borrar la cache, borrar los css antiguos, etc. También he comprobado que la carpeta y los archivos css tengan los permisos adecuados, y sigue sin funcionar.

    No se si alguien me puede dar alguna idea de lo que puede estar pasando. Realmente no es un error crítico, porque puedo funcionar con los css sin agrupar. Pero no estaría mal saber por qué pasa esto.

    Gracias de antemano.
     
  2.  
    Comunidad Magento orgullosamente patrocinada por el hosting y vps magento de FactoriaDigital.com.
  3. manuel_gdb

    manuel_gdb Nuevo usuario

    5
    0
    1
    Ok, ya sé de donde viene el error.

    En el antiguo hosting estaba usando un cdn para cargar las imágenes, los css y los js. Al cambiar de hosting, al parecer el cdn está teniendo errores de caché (sólo con los css, no con las imágenes, cosa rara) y no devolvía los css, por eso no se encontraba el recurso. He desactivado el cdn para los css y va todo bien.

    Saludos!
     
Cargando...

Compartir esta página

Cargando...