Error con envío basado en tablas

He creado una tabla básica, considerando precio v/s destino, pero Magento rechaza la región.... he probado con ISO 3166-2 , pero nada... alguna idea para abordar el tema....Envio.jpgenvio2.jpg
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

El texto en región debe ser el mismo que el que esté en la tabla de Magento directory_country_region y directory_country_region_name, si no aparecen ahí las provincias, las tendrías que dar de alta directamente en la tabla.
Al ser el caso de Chile, desconozco si existe alguna opción que te pueda rellenar esos valores ahí o te permita subir la tabla de tarifas fácilmente.

A ver si otro usuario te consigue ayuda con algo más claro al respecto.

Un saludo.
 
Hola nuevamente, he actualizado ambas tablas con SQL

BASE_DATOS.jpg

Luego ya puedo ver las regiones para el caso de ajuste de impuestos y al ingresar la dirección del cliente

calculo_impuesto.jpgcambiodeireccion.jpg

Pero cuando subo la tabla con los valores de envíos por regiones

flete.jpg

Magento rechaza los nombre ....

error_tabla.jpg

Alguna idea por donde seguir intentando....
desde ya muchas gracias
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Rodrigo,

¿Tienes configurado Magento con el idioma es_CL? De no ser así, creo que no te cogerá bien el valor de la tabla.
De todas formas, podrías incluso probar a introducir los mismos valores de región para en_US en la tabla directory_country_region_name a ver si así te lo coge bien.

Un saludo.
 
Hola Toni,
Tengo configurado el idioma en español España, desde acá ... con un paquete de Eurolito es_ES.cvs

es.jpg

He probado cambiar cambiar la info de la tabla ....

bdD.jpg

No obstante el error se mantiene igual para todas las regiones al intentar subir estos datos....

País,Región/Provincia,Código Postal,Subtotal del pedido (y anteriores),Precio de envío
CL,Aisén,*,0,20
CL,Antofagasta,*,0,20
CL,Arica y Parinacota,*,0,20
CL,Atacama,*,0,20
CL,Biobío,*,0,5
CL,Coquimbo,*,0,5
CL,La Araucanía,*,0,8
CL,Libertador General Bernardo O'Higgins,*,0,3
CL,Los Lagos,*,0,6
CL,Los Ríos,*,0,6
CL,Magallanes,*,0,20
CL,Maule,*,0,4
CL,Región Metropolitana de Santiago,*,0,2
CL,Tarapacá,*,0,15
CL,Valparaíso,*,0,4
CL,Ñuble,*,0,7
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Rodrigo,

Pues llegados a este punto y al no tener posibilidad de "meter mano" en la página para echarle un vistazo, no te sabría decir por donde continuar, ya que, aparentemente, lo necesario para que la importación de la tabla de tarifas te funcione lo tienes bien.

A ver si algún usuario del foro se ha visto en esa situación y puede echarte un cable.

Un saludo.
 
Estimados, el problema estaba dado finalmente, en los datos de la tabla que intentaba subir, lo primero las tildes del encabezado generaban conflicto y lo segundo los nombres de las regiones, se deben cambiar por los códigos correspondientes de esa forma he podido resolver el tema, espero que sea útil para los que se encuentran recién comenzando en Magento como yo.

Saludos,
RG

error-tabla.jpg
 
Arriba