Error en la instalación con composer

Error de Instalación.jpg

Estimados, como ya se imaginarán se muy poco de Magento, he descargado los archivos del modulo de pago en public_html/transbank/webpay-magento2, pero me encuentro con el mismo error, que estoy haciendo mal? (o muy mal jejeje), será posible que sea un error de memoria, alguna idea...
 
Última edición:

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Rodrigo,

Por lo que se puede ver, el proceso composer no consigue acabar, ni para bien, ni para mal, ya que se termina el proceso forzosamente desde el servidor. Realmente parece que composer detecta bien el paquete que intentas instalar, pero no consigue continuar por culpa de algún bloqueo en el servidor.

Te recomiendo que contactes con tu hosting para que te puedan decir algo más concreto al respecto, es posible que sea por falta de memoria, por timeout o incluso porque tengan bloqueado allow_furl_open, del cual hace uso composer para descargar paquetes.

Un saludo.
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Rodrigo,

Ese error sí que es por limitación de memoria. Puedes seguir los pasos que te recomienda composer en el enlace que te aparece. Te lo dejo a continuación para mayor facilidad: Troubleshooting - Composer

Verás que puedes obtener desde consola el valor actual de memory_limit. Magento recomienda tenerlo al menos a 2GB, tal y como indica en su documentación: Hardware recommendations | Magento 2 Developer Documentation

Un saludo.
 
Sigo con el tema, te comento, se aumento la memoria a 2 GB, esta corriendo PHP 7.3, pero sigo con problemas.... que estaré haciendo mal....
Error05_1030.jpg
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Veo que has instalado bien el paquete a través de composer, pero ahora estás utilizando el ejecutable de Magento mal.
Fíjate que utilizas magento directamente, pero no está en el directorio en el que estás, el ejecutable está en bin/magento, por lo que el comando debería ser:

Bash:
php bin/magento module:enable Transbank_Webpay --clear-static-content
Un saludo.
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Debes ejecutar el comando que te pasé desde public_html, no debes entrar en bin. Si entras en ese directorio, entonces debes ejecutarlo sin bin/magento, quedando solo con magento

Lo más sencillo es que te mantengas en public_html y ejecutes el comando tal y como te lo envié.

Un saludo.
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
No lo has activado aún.

Cuando te envié el comando corregí después el mensaje, me dejé una mayúscula. Necesitarás habilitarlo y posteriormente ejecutar el comando de upgrade de Magento, serían los siguientes:

Bash:
php bin/magento module:enable Transbank_Webpay --clear-static-content
php bin/magento setup:upgrade

Un saludo.
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Puede que el módulo ya estuviera activado en una de las ejecuciones anteriores.
Para comprobar que está instalado puedes ejecutar:

Bash:
php bin/magento module:status
Donde te saldrá un listado con los módulos activados y los módulos desactivados respectivamente. Busca si Transbank_Webpay está entre los módulos activados. De ser así, procede con el siguiente comando de upgrade de Magento y ya deberías tenerlo 100% instalado.

Bash:
php bin/magento setup:upgrade
Un saludo.
 
Arriba