Error en Mage/Payfilter/Model/Entity/Backend/Payment/Methods.php

ososoft

Nuevo usuario
Buenas, tengo un problemilla.

Ayer me funcionaba bien magento, hice una prueba de pedido y todo estaba bien, pero esta mañana estoy arreglando el tema de los envios y ahora al mirar cualquier producto me aparece este error:

HTML:
Warning: include(Mage/Payfilter/Model/Entity/Backend/Payment/Methods.php) [function.include]: failed to open stream: No such file or directory  in /var/www/magento/app/code/core/Mage/Core/functions.php on line 73
Trace:
#0 /var/www/magento/app/code/core/Mage/Core/functions.php(73): mageCoreErrorHandler(2, 'include(Mage/Pa...', '/var/www/magent...', 73, Array)
#1 /var/www/magento/app/code/core/Mage/Core/functions.php(73): __autoload()
#2 [internal function]: __autoload('Mage_Payfilter_...')
#3 /var/www/magento/app/code/core/Mage/Core/Model/Config.php(964): class_exists('Mage_Payfilter_...')
#4 /var/www/magento/app/Mage.php(317): Mage_Core_Model_Config->getModelInstance('payfilter/entit...', Array)
#5 /var/www/magento/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(330): Mage::getModel('payfilter/entit...')
#6 /var/www/magento/app/code/core/Mage/Eav/Model/Entity/Abstract.php(555): Mage_Eav_Model_Entity_Attribute_Abstract->getBackend()
#7 /var/www/magento/app/code/core/Mage/Eav/Model/Entity/Abstract.php(1269): Mage_Eav_Model_Entity_Abstract->walkAttributes('backend/afterLo...', Array)
#8 /var/www/magento/app/code/core/Mage/Eav/Model/Entity/Abstract.php(814): Mage_Eav_Model_Entity_Abstract->_afterLoad(Object(Mage_Catalog_Model_Product))
#9 /var/www/magento/app/code/core/Mage/Core/Model/Abstract.php(216): Mage_Eav_Model_Entity_Abstract->load(Object(Mage_Catalog_Model_Product), 17257, NULL)
#10 /var/www/magento/app/code/core/Mage/Checkout/controllers/CartController.php(94): Mage_Core_Model_Abstract->load(17257)
#11 /var/www/magento/app/code/core/Mage/Checkout/controllers/CartController.php(147): Mage_Checkout_CartController->_initProduct()
#12 /var/www/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(367): Mage_Checkout_CartController->addAction()
#13 /var/www/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(247): Mage_Core_Controller_Varien_Action->dispatch('add')
#14 /var/www/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#15 /var/www/magento/app/Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch()
#16 /var/www/magento/index.php(52): Mage::run()
#17 {main}
No he instalado ni desistalado nada, solo he cambiado en
admin/configuracion/ventas/configuraciones de envio/origen
que de serie venia puesto de estados unidos y he puesto España.

He visto en el foro de magento esta respuesta a un error parecido al mio:
http://www.magentocommerce.com/boards/viewthread/29668/
pero me da miedo borrar nada de la base de datos.

Alguna idea??
 

error403

Miembro
/var/www/magentp/app/code/core/Mage/Payfilter/Model/Entity/Backend/Payment/Methods.php

Ese archivo esta? Que version de Magento tienes instalada?

edito:
Al parecer tienes instalada un extension que agrega un atributo que es lo que borran en el post que pusiste. Posiblemente la extension no sea estable. No hay problema en que borres esos campos como comentan en el post. es "safe" :P aunque obviamente no tendras la funcion de esa extension.
 
Última edición:

ososoft

Nuevo usuario
Ok, tienes razon he corrido esta secuencia:

HTML:
DELETE FROM `eav_attribute` where attribute_code = 'product_payment_methods';
   DELETE FROM `core_resource` where code = 'payfilter_setup';
   ALTER TABLE `customer_group` DROP `allowed_payment_methods`;
Y todo ha vuelto a la normalidad.

Que descanso !!
 
Última edición:
Arriba