Error Pop UP en Alemán al no aceptar las condiciones de venta

Tema en 'Soporte General' iniciado por Anibal, 28/10/15.

  1. Anibal

    Anibal Nuevo usuario

    9
    2
    3
    Hola Magenteros!!!

    Tengo un problema en mi tienda que no sé solucionar. Cuando llego a la parte de hacer el checkout, al final del proceso, he activado la opción para que haya que picar la casilla de "acepto las condiciones de venta", de esta manera si el cliente no pica esta casilla, sale el POPUP de error que dice que tienen que aceptar estas condiciones para poder continuar.

    Hasta ahí todo lo he hecho correctamente, el problema es que este POPUP de error viene por defecto en alemán, y no me permite cambiarlo de ninguna manera, he buscado en la carpeta "local" pero no encuentro este texto para poder cambiarlo. Tampoco lo puedo traducir habilitando la "traducción en línea", ya que al ser un POPUP, no me permite editarlo.

    El mensaje de error dice lo siguiente:
    Mensaje de la página:
    Bitte stimmen Sie den Allgemeinen Geschäftsbedingungen zu, bevor Sie die Bestellung aufgeben.
    Aceptar.

    ¿Dónde puedo cambiar este mensaje para traducirlo?
     
  2.  
    Comunidad Magento orgullosamente patrocinada por el hosting y vps magento de FactoriaDigital.com.
  3. KiwiWeb

    KiwiWeb Miembro

    278
    14
    18
    Buenos días,
    Lo normal es que esos pop ups sean parte de la Plantilla y estén incluidos por JavasCript (en mi experiencia al menos), y lo que suelen tener es un menu de configuración dentro del admin, como cada plantilla es un mundo no sabría decirte donde encontrarlo, llegados a esto puedes mirar el manual de intrucciones (si lo trae) o preguntar a los desarrolladores.

    Como última opción puedes bajarte todos los directorios y ficheros dentro de la carpeta "app/" y usar algúna herramienta (como el SublimeText) que permite buscar cadenas de texto en todo el código y así ver donde se esta escribiendo esa parte.

    Un saludo y espero haber sido de ayuda, suerte.
     
  4. Anibal

    Anibal Nuevo usuario

    9
    2
    3
    Gracias por respoder KiwiWeb.

    El problema es que no es una extensión comercial de Magento, sino que es una opción que ya trae el propio Magento.

    Mi versión de Magento es la 1.8.1.0

    Se puede activar esta opción entrando en el backend en Sistema/Configuración/Ventas/Finalizar compra/
    Dentro de la primera pestaña, opciones de compra, ahí dentro hay que habilitar con "SI" Enable Terms and Conditions.

    Pero no hay ninguna opción mas que me permita cambiar el idioma de ese mensaje.

    Un saludo.-
     
  5. Anibal

    Anibal Nuevo usuario

    9
    2
    3
    Solucionado!!!

    Al final lo he logrado encontrar usando la herramienta SublimeText como me recomendaba KiwiWeb. Millones de gracias!!!

    El archivo que hay que modificar está en la carpeta app/locale/es_ES
    El archivo a modificar es Mage_XmlConnect.csv

    Lo he abierto y editado con el block de notas y sustituido esa frase por la que yo quería en español.
    Después he vaciado la caché y ya se ha mostrado el mensaje en español.

    Muchas gracias!!!
     
Cargando...

Compartir esta página

Cargando...