Imagen producto base borrosa con blur

walthermores

Nuevo usuario
Hola buen día! quisiera saber si alguien me puede orientar en como resolver un problema que tengo con las imágenes en M1.9
La imagen base se ve borrosa, la imagen de carga de producto inicial es de buena calidad, tras haber analizado el porque sucedió esto, detecto que la imagen base se ve así porque cuando se carga llama a la miniatura, tal como verán en la imagen que les adjunto o en el enlace.
Mi pedido es porque no soy experto en programación y no se donde cambiar la ruta para hacer el llamado de la imagen correcta, y aún no conozco bien la estructura de archivos de magento.
Les dejo una segunda imagen que es la que muestra como se corrige el error si cambia el tamaño en la ruta
El enlace para que lo vean, esto sucede en todos los productos: https://www.itx.com.ar/hi-butterfly.html
 

Adjuntos

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola walthermores,

La ruta que indicas no es que esté mal en si, ya que esa ruta se genera automáticamente en la plantilla por Magento, cuando se redimensiona una imagen. Es decir, esa imagen, en la ficha de producto y en su plantilla correspondiente ( entiendo que en gallery.phtml o similar ) tiene una redimensión de 300x389, por lo que Magento la genera y la guarda en caché, para luego devolver su ruta. Habrán tantos directorios como redimensiones se hayan utilizado de esa misma imagen, por lo que deberías entrar a ese archivo ( que puede ser ese, otros o ambos a la vez, dependerá de tu plantilla ) y modificar la redimensión de la imagen base por el tamaño que necesites.

Un saludo.
 

walthermores

Nuevo usuario
Muchas gracias por explicarme el concepto! te comento que bajado el achivo gallery.phtml, pero parece no ser ese el que hay que modificar, que que no tiene ninguna referencia de resize.
habra forma de identificarlo con el f12 de inspeccionar pagina en firefox dev?
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Te puedes ayudar del bloque de plantillas que saca Magento, para que veas qué contenido está en cada uno de los archivos phtml y así identificarlos mas fácilmente. Te dejo una guía a continuación para ver cómo activarlo: https://www.templatemonster.com/help/es/how-to-use-magento-debug-tool.html
Ten en cuenta que depende de la tienda y se ve afectado por la IP que pongas en el campo superior, por lo que tendrías que poner tu IP para que no aparezcan las plantillas a todo visitante en la página. Puedes obtener tu IP en esta página: http://cualesmiip.com/

Un saludo.
 

walthermores

Nuevo usuario
Exelente!! dentro seguí la ruta y en el archivo media.phtml en "product image", corregí los valores entonces cuando llegas de la grilla general al producto te muestra la imagen base bien definida. Ahora si se te ocurre ver otra foto para ver detalles del producto, te trae una imagen borrosa, le estuve probando de cambiar los valores pero no doy con la solución, quizás hay algo que se me escapa
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Es posible que en las miniaturas, incluso en la imagen que te hace zoom, se estén redimensionando con otros tamaños distintos al que acabas de modificar y en otros archivos.
Por lo pronto, veo que la miniatura se genera con 105x138, y una imagen pequeña de la parte del zoom con 265x265.

Ten en cuenta, que la imagen original debería ser superior a esas resoluciones, ya que también puede ocurrir el efecto contrario, que la imagen se estire y por tanto, quede también borrosa.

Un saludo.
 

walthermores

Nuevo usuario
Buen día! tal como mencionaste la imagen generada es de 265x265, he revisado varios archivos pero no logro descubrir en cual corregir el valor, porque basicamente no logro ver donde esta el archivo, mas allá que en media.phtml es el que se muestra, encontré otras indicaciones en el siguiente link: https://astrio.net/blog/images-resize-in-magento/ y si bien son otros archivos relacionados parece que no son los indicados, pero mi explicación hay que tomarla con pinzas ya que yo no soy un experto
 

walthermores

Nuevo usuario
te comento que solucione, el tema de la calidad de imagen, de las miniaturas también todo es en el archivo media.phtml de la carpeta Prozoom, solo queda solucionar el tamaño, ya que cuando linkeas la miniatura ésta abre la imagen grande pero reducida a lo que debería ser en relación a la imagen base inicial
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Tal y como te decía anteriormente, creo que eso es debido a que la imagen original tiene menor resolución de la que se quiere mostrar, por ejemplo, la imagen base es de 900x900 y estás redimensionándola a 1200x1200, por lo que se estira y pixela.

¿Puedes verificar que no sea ese el caso?

Un saludo.
 

walthermores

Nuevo usuario
hola buen día! no sería este el caso, porque la imagen base es de 1240x1488 px, tras haber corregido los valores que antes mencioné, el problema de las imágenes pixeladas esta resuelto por completo; el problema pendiente es el del tamaño de las miniaturas: la imagen del producto base se carga sin pixelados y a una medida grande como la que le configure, esa medida que le configuré es un rectángulo, (ejemplo 500x600), pero las miniaturas no cargan ese rectángulo, se cargan sobre un cuadrado, (500x500), esto ocasiona que la imagen de la miniatura al cargarse en el área de la imagen base, se reduzca, entonces modifico la linea que supuestamente corregiría ésto pero me doy con que los valores que puedo corregir no son iguales a los anteriores, solo tengo la posibilidad de corregir el ancho o el alto ambos por separado, pero siempre ésta sujeto a una medida, en la imagen te te adjunto podrás ver que el valor que menciono es 1488 pero el siguiente es una especie de código, y si modifico el otro valor es lo mismo. Entonces llegue a la conclusión de que la imagen que se carga inicialmente no es la misma que la de las miniaturas, por ende las miniaturas se manejan desde otro archivo, el cual no puedo ver cual es, porque no se muestra en el debug
 

Adjuntos

walthermores

Nuevo usuario
Es posible que se pueda corregir, en view.xml, según me ha comentado un colega indu, que tengo como amigo en facebook, de ser así te lo hago saber, de todos modos cualquier aporte es muy valioso para mi
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola,

Si se tratase de un Magento 2 sí, puede estar especificado en view.xml, del tema en concreto que estés utilizando.
Por otro lado, si estás utilizando un módulo para las imágenes, puede que esa configuración esté definida en la propia sección del módulo en el administrador de Magento.

Un saludo.
 

walthermores

Nuevo usuario
buena respuesta, no, no es magento 2, es m1.9, y para ser honesto no se si el sistema de imágenes es manejado por un modulo yo creo que no, pero no podría asegurar eso,
 
Arriba