Instalación de Magento en Mac con Xampp

OSdave

Super Moderador
Miembro del equipo
hola Majo, y bienvenido.
La verdad que no voy a poder ayudarte mucho, nunca he tenido un mac entre las manos :(
Pero si dices que es con el xampp, puede ser que sea muy parecido a un pc, ¿no?
O sea que el xampp te instala una serie de cosas, de las cuales, una tienes que reemplazar por el fichero que se indica en el post de instalacion en local.
La verdad que sera interesante saberlo para tod@s l@s m@aqueros: mi consejo, sigue los pasos de instalacion en pc, y cuando algo falla pregunta por aqui: seguro que hay algunos que saben más que yo.
Y si lo consigues, no olvides de decirnos lo que hiciste, para que sirva para toda la comunidad.
saludos
 
Última edición por un moderador:

Xan

Nuevo usuario
Buenas, Majo yo también trabajo con mac, has probado con mamp en lugar de xampp para OSX?, aún no me he instalado magento, pero para wordpress mamp me va mucho mejor que xampp.

En cuanto haga la prueba os cuento.

Salud,
xan.
 

Majo

Nuevo usuario
Hola Osdave,

Muchas gracias por la respuesta. El tutorial de instalación fue mi primera opción pero nada de nada no consigo que vaya. El caso es que las librerías que comentan para windows no van en mac.
 

OSdave

Super Moderador
Miembro del equipo
Hola Osdave,

Muchas gracias por la respuesta. El tutorial de instalación fue mi primera opción pero nada de nada no consigo que vaya. El caso es que las librerías que comentan para windows no van en mac.
ya me lo imaginaba que no iba a ser tan facil :triste:.
A ver si con el wamp hay más excito, sino habria que ver si dicen algo al respecto en el foro ingles.
suerte
 

scratch

Nuevo usuario
Si ... pero no ....

Este es mi 1er post, asi que ¡hola a todos! :hola:

A ver, estoy intentando instalarlo en local mediante MAMP:

1- No sé si es porque tengo tambien Joomla instalado en local pero no llego mas alla de "Configuration" en el panel de "Installation". Me tiene frito con el tema del localhost, ports y demas .... creo que he probado todas las combinaciones posibles y no hay manera. Debe ser que mezcla informacion de la base de datos de Joomla ... y como soy casi un ignorante en cuestiones de php-mysql ....

2- Visto los resultados del 1er punto, decidi probar con el portatil al no haber hecho nunca pruebas con ningun CMS y en este sentido esta "virgen". Instalo MAMP y me bajo de nuevo el pack Magento. En este caso si me funciona y hago la instalacion al completo.

Me da la opcion de ir a FRONT o BACK y me decanto por FRONT. Pues bien, la "Homepage" esta vacia (imagino que es obvio) pero tanto los botones de Login, My Account, Checkout, ... me da error y me dice que no puede conectarse al servidor "localhost" ... total, que no puedo hacer nada :(


no se, borrare la base de datos y empezare de nuevo :pensando: ....



saludos :)
 

OSdave

Super Moderador
Miembro del equipo
hola scratch, y bienvenido!
para ser tu prmier mensaje, esta lleno de esperanzas:jeje:
En el foro americano he encontrado algo de info que te puede ayudar, creo:
En Español
Con MAMP 1.7 FREE OS X Tiger 10.4.9 se instala normal todo bien pero cuando se carga la pagina principal no se ven los datos de los productos solo las imagenes.
Solucion
Abrimos el archivo php.inio que se encuentra en /Aplications/MAMP/conf/PHP5/php.ini con Textedit
En la seccion donde encuentres ;zend_extension="/Applications/MAMP/bin/php5/lib/php/extensions/no-debug-non-zts-20050922/eaccelerator.so" activalo quitandole el ; esto activara el modulo eAceelerator .
En la siguiente linea eaccelerator.shm_size="32" cambia el avlor a 32 como dice lukasz con esto funcionara correctamente.
Saludos
pruebalo y dinos que tal...
visto aqui: http://www.magentocommerce.com/boards/viewthread/257/P15/#t3681
 
Última edición:

scratch

Nuevo usuario
gracias OSdave :contento2:

a veces, esto de la programacion llega a sacar de quicio ... como dije, borre la base de datos y volvi a empezar sin exito.

Total, a lo bruto, he borrado MAMP y Magento, he vuelto a instalar todo y esta vez vuelve a "funcionar" pero se repite el mismo mensaje incluso modificando el "php.ini" :triste:

el mensaje es el siguiente:
Safari no puede abrir la pagina ( ... ) porque porque no ha podido establecer una conexion segura con el servidor "localhost"
Por lo que dice el mensaje, hay algun dato que yo he introducido que no le gusta pero asi es como mas lejos he llegado en la instalacion.

Dejo los datos que tengo puesto (por si alguien ve alguna aberracion :desentendido: ) en modo LOCAL:

Databe Connection
Host: localhost
Database name: magento
User Name: root
User pass: (root)

Default Store:
Host: localhost
Base Path: /magento/
Protocol: http
Port: 8888

Secure Connection
Secure Host: localhost
Secure Base Path: /magento/
Secure Protocol: https
Secure Port: 8888 ----- > :niidea: ????
Como decia, diria que el mensaje del navegador tiene que ver con los datos de "Secure Connection" de ahi que ponga interrogantes. Esto tiene que venir alguien experto en php/mysql porque yo no tengo idea y voy dando palos de ciego. Soy un absoluto ignorante en estas cosas .
 

Xan

Nuevo usuario
Hola a todos...
scratch, prueba poniendo port 8889... hablo por pura intuición o porque recuerdo vagamente algún problema así.

Saludos!
 

Xan

Nuevo usuario
lo conseguí!

buenas... después de unos meses hoy me he puesto realmente a instalar magento en mi mac...

lo he hecho con un servidor Mamp última versión, 1.7 (esta versión ya tienen php 5.2) y con la versión 1 de Magento que ha salido hace unos días.

Me ha dado algunos errores pero al final lo he conseguido, intentaré recordarlo todo:

*Una vez instalado el mamp, creas la base de datos (hay manuales de mamp por ahí que os servirán bien) en este punto es importante recordar qué usuario y contraseña le das a la bbdd, por defecto es "root" "root".

*pones el paquete de magento (desempaquetado) en la carpeta htdocs que hay dentro de la carpeta Mamp que encontrarás entre tus aplicaciones. Si te vas con tu navegador al puerto donde tienes el localhost
(http://localhost:8888/) en mi caso, ya te aparecerá la carpeta de magento.
Entras y seguramente te de errores....

* yo los he solucionado cambiado las preferencias del Mamp: en la pantallita del mamp donde se inician y se paran los servidores, tienes una opción de "preferencias", en "iniciar/detener" (lo he dejado igual), en "puertos" ya los tenía en Apache 8888, MySQL 8889...ahora viene lo importante, en "PHP" tienes que tener marcado "php5", selecionado "Zend Optimizer" y en caché "eAccelerator".

*hasta aquí bien... lo último que he hecho es abrir la página de la configuración del servidor del mamp (la que has utilizado para crear la bbdd, la que te aparece si en la pantallita del mamp clicas en "abrir página de inicio"), una vez aquí te vas a "eAccelerator" y en "actions" tienes que tener la opción "optimazer" en modo "enable" y la de "caching" en "disable" (el resto de actions no las he tocado). Por lo menos esta es la configuración que a mi me ha funcionado.

Aún no he jugado con nada más pero la instalación está perfecta.

Espero que os ayude,

Xan.
 

Xan

Nuevo usuario
instalar 2 versiones de mamp

Buenas Scratch y compañía... veo que ya trabajabas con mamp y tienes webs previas. Yo me encontré con el problema de que la verisón del mamp que tenía era la antigua y aún no tenía php5.2. que es lo que necesitas para magento. Necesitaba la nueva pero eso implicaba que en principio tenía que cambiar todo lo que tenía al servidor actualizado y liarme con actualizaciones etc... como me daba mucha pereza probé a instalar el nuevo mamp en una carpeta con otro nombre, la llamé "mamp2". Supongo que podrían funcionar ambos con nombres diferentes si empezase a cambiar los directorios por defecto que busca el mamp, pero como eso también me daba pereza los dejé igual, simplemente cambio de nombre los directorios de los dos "mamps" que tengo instalados según quiera utilizar uno u otro. Y listo!

gracias OSdave :contento2:

a veces, esto de la programacion llega a sacar de quicio ... como dije, borre la base de datos y volvi a empezar sin exito.

Total, a lo bruto, he borrado MAMP y Magento, he vuelto a instalar todo y esta vez vuelve a "funcionar" pero se repite el mismo mensaje incluso modificando el "php.ini" :triste:

el mensaje es el siguiente:


Por lo que dice el mensaje, hay algun dato que yo he introducido que no le gusta pero asi es como mas lejos he llegado en la instalacion.

Dejo los datos que tengo puesto (por si alguien ve alguna aberracion :desentendido: ) en modo LOCAL:



Como decia, diria que el mensaje del navegador tiene que ver con los datos de "Secure Connection" de ahi que ponga interrogantes. Esto tiene que venir alguien experto en php/mysql porque yo no tengo idea y voy dando palos de ciego. Soy un absoluto ignorante en estas cosas .
 

power74

Nuevo usuario
yo lo que he hecho ha sido editar los archivos host redireccionando por ejemplo dominio.com a 127.0.0.1 y cuando da error en la direccion web porque no reconoce localhost en vez de localhost pones dominio.com y como previamente esta redireigido a 127.0.0.1 funciona sin problemas.

Para redirigir dominio.com a 127.0.0.1 hay que abrir terminal y teclear esto

sudo pico /private/etc/hosts

luego te pide password y luego tecleas

127.0.0.1 domino.com

luego pulsas Control + X y te pide guardar cambios pulsas Y

asi ya tienes editado el archivo host y cada vez que teclees dominio.com te redigira al localhost.

Saludos a todos espero que os sirva este truquillo ;)
 
Arriba