Instalar extensiones sin que se actualice Magento

nk82

Nuevo usuario
Hola, como la última versión de Magento no se lleva bien con el importador de OsCommerce, tuve que instalar la versión 1.1.8 que si que funciona bien con él.

El problema es que al tratar de instalar desde Magento Connect la extensión de OsCommerce, se me actualiza todo Magento la última versión, quedándome inservible el importador de OsCommerce así como algún otro fallo que hay con esa versión.

La pregunta es si habría manera de instalar la extensión de OsCommerce de manera que no me actualice Magento.
 

nk82

Nuevo usuario
No lo tengo instalado, está tal cual viene en el paquete de la 1.1.8 ya que es una instalación limpia (base de datos incluída).

Para mi que el problema es que la extensión de OsCommerce incluye entre sus dependencias que se instale la última versión de Magento. Lo malo es que no sé cómo hacer para bloquear esa actualización o instalar "a mano" la extensión.

Es una putada, porque echando cuentas, tengo mas de 5000 productos para importar, lo cual quita a cualquiera las ganas de pasarse a Magento xD
 

OSdave

Super Moderador
Miembro del equipo
tienes razon, probablemente tiene en sus dependencias la ultima version: fijate en el Oscommerce/etc/config.sql si hay algo de depends.
A mi no hay nada que me quite las ganas de pasarme a Magento, estoy tan cansado de osc. Pero estoy pensando que para importar mis productos-categorias-clientes, probablemente sera más facil generar ficheros CSV con la estructura de magento desde osc: así puedo recuperar los campos que añadi a lo largo de los años que he usado osc y controlar mejor lo que esta pasando.
 

nk82

Nuevo usuario
No me aparece el fichero que me dices, lo mas similar es uno con extensión XML en el que no hay nada interesante.

Lo más similar que encontré es el fichero package.xml, que es el que debe estar en el directorio del servidor de Magento, junto al .tar.gz de la aplicación, indicando el contenido de esa extensión. La parte de la que hablo es la siguiente:

<required>
<php>
<min>5.2.0</min>
<max>6.0.0</max>
<exclude>6.0.0</exclude>
</php>
<pearinstaller>
<min>1.6.2</min>
</pearinstaller>
<package>
<name>Mage_Core_Adminhtml</name>
<channel>connect.magentocommerce.com/core</channel>
<min>1.0.19700</min>
</package>
</required>

Pero no veo la manera de crear algo similar (como si fuera un repositorio de extensiones) de manera local (las pruebas que hice no me resolvieron nada).

Gracias por tus respuestas OSdave, yo tampoco tengo ganas de usar OsCommerce, está muy desfasado.
 

Damian Culotta

Nuevo usuario
@OSdave

Ja ja ja, te entiendo.
Yo estoy armando una serie de ejemplos prácticos para cada uno de las entidades que posee la Api. Hasta ahora solo pulbiqué dos (los casos más naif).
Espero en breve seguir posteando sobre manejo de Categorías, Productos y demás. (Son cosas que en producción ya tengo funcionando)
;-)
 

raynexus

Nuevo usuario
Instalar extensiones de php en Cpanel para la instalacion de Magento

Hola, estoy tratando de instalar magento en un servidor cpanel y me indica que debo cargar las extensiones de php "mcrypt" y "pdo_mysql"... mas no se como activarlas. Se que esto no tiene nada que ver con la instalacion de magento, pero les agradeceria si me pueden ayudar...
 

Xarlie

Super Moderador
Miembro del equipo
@raynexus, esas extensiones son de PHP y no de magento. Por lo que tendrás que ponerte en contacto con tu proveedor de alojamiento para que te indique si puede activar en el php (tendrá que recompilar) ambas extensiones.
 
Arriba