Locale Settings sólo funcionan si cambio carpeta en_US

mipecera

Nuevo usuario
Hola, he descargado unas 30 veces la traducción al español de Magento (incluso distintas fuentes) sin que funcione, siguiendo las instrucciones pertinentes.

Sin embargo, si intercambio los nombres de las carpeta en_US y es_ES, funciona en parte. Es decir, que si le digo que locale es español y coloco la carpeta es_ES, sigue en inglés. Pero si le engaño y le digo que locale es english (USA) y la carpeta en_US en realidad es la española con el nombre cambiado a en_US, entonces sí aparece el idioma español, pero no el admin, sólo en el front end.

Instalé Magento con un autoinstalador de un servidor preparado para Magento, y uso la versión 1.1.6 que debería ser la última. Al instalarlo, le indiqué que la configuración local sería españa. No sé si tiene algo que ver, si a alguien le ocurre algo similar...

Lo que intento conseguir especialmente es tener el backend en español.

gracias
 

zeusco

Nuevo usuario
Hola, he descargado unas 30 veces la traducción al español de Magento (incluso distintas fuentes) sin que funcione, siguiendo las instrucciones pertinentes.

Sin embargo, si intercambio los nombres de las carpeta en_US y es_ES, funciona en parte. Es decir, que si le digo que locale es español y coloco la carpeta es_ES, sigue en inglés. Pero si le engaño y le digo que locale es english (USA) y la carpeta en_US en realidad es la española con el nombre cambiado a en_US, entonces sí aparece el idioma español, pero no el admin, sólo en el front end.

Instalé Magento con un autoinstalador de un servidor preparado para Magento, y uso la versión 1.1.6 que debería ser la última. Al instalarlo, le indiqué que la configuración local sería españa. No sé si tiene algo que ver, si a alguien le ocurre algo similar...

Lo que intento conseguir especialmente es tener el backend en español.

gracias

Veamos, me intereso tu problema y trate de hacer lo mismo que tu y tambien me dio error, toncs viaje un rato por google y descubri lo sgte:

1.- Los paquetes (inclusive los de lenguaje)se instalan desde MAGENTO CONNECT.
2.- Si estas usando tu PC como servidor y al tratar de instalar el Lenguaje te da error toncs tienes que setear en el Magento Connect que pueda bajar los paquetes que estan en BETA, me imagino que en el hosting debiera ser igual.
3.- Debes bajar el mismo paquete de lenguaje que tienes configurado en el administrador, en mi caso yo baje este:
http://www.magentocommerce.com/extension/395/magento-community-modules--spanish-argentina-language-pack
y en la configuracion del locale puse Español Argentina
4.- Tambien limpie el cache del Magento

Y listo ahora el administrador aparece en Español.

EEEEEEEEEEEEEEEEE bueno aparece CASI todo en español, si buscas en los foros te daras cuenta que puede ser que los paquetes de lenguaje no esten 100% traducidos, o mejor dicho que nuestra version de Magento tenga mas cosas que la traduccion bajada.

Saludos
 

mipecera

Nuevo usuario
Sí, simplemente refrescando la caché de Magento se resolvió el problema.

No subí los paquetes desde Magento Connect, los subí directamente al servidor vía FTP, y los reconoció una vez refresqué la caché (además de configurar el idioma local como español, claro)
 

mipecera

Nuevo usuario
como dice cbccharlie no tenía controlado el tema de la caché de Magento, cuando la refresqué, por fin sí cogió las settings locales
 
Arriba