Marca de Agua

spok01

Nuevo usuario
Hola

Estoy en los ultimos detalles para la tienda que estoy montando, sin embargo uno de mis ultimos dolores de cabeza a sido con la marca de agua, ya que quisiera poner una marca de agua que tiene formato .png y al aplicarla la aplica mal. (No toma en cuenta la transparencia)

Alguna idea sobre que modificar en el archivo Gd2.php para que trabaje bien con los archivos con transparencia.
 

spok01

Nuevo usuario
La situacion es que yo en mis imagenes pongo muchas veces mi logo, entonces el logo debe estar semi transparente (al 15%; y asi esta definido en el .png) y al aplicarse se aplica una capa general y mi logo se pierde :triste:.

Quiza deba utilizar una sola imagen en formato .gif, :triste:
 

arwin

Nuevo usuario
creo que...

Me parece que magento ya aplica a las marcas de agua efecto transparente, lo que no se es donde se puede cambiar ese % que dices. Por lo menos con los Gifs.
 

spok01

Nuevo usuario
arwin:El porcentaje que comento se define en un editor de imagenes; sin embargo no es soportado en algunos formatos (.jpg, .gif, etc...)

Aqui dejo un ejemplo de la diferencia entre marca de agua aplicada de forma manual y de forma automatica (por magento).

Haber si alguien tiene otra idea.


Saludos

Imagenes:
1.- Texto Transparente (.png)
2.- Imagen Original
3.- Marca de Agua aplicada por Magento
4.- Marca de Agua aplicada Manualmente
 

Adjuntos

nk82

Nuevo usuario
Hola, acabo de probar lo de las marcas de agua usando un PNG con transparencia (sólo alrededor de la imagen y con el borde algo alisado) y me funciona perfectamente, pero al parecer es el propio Magento el que define el porcentaje de opacidad de la capa.

Por lo que pude leer por ahí, este valor es por defecto 30%, pero puede cambiarse editando el archivo magento\lib\Varien\Image.php donde pone "$watermarkImageOpacity=30" cambiando el valor de 30 al deseado.

Para mas info, uso Inkscape para exportar mis diseños de vector a PNG y tengo la versión 1.1.8 de Magento sobre un servidor local en Ubuntu server 8.10.
 

spok01

Nuevo usuario
Hola nk82, intente lo que comentabas, sin embargo me sigue sin funcionar correctamente, ya que aplica un color general sobre toda la imagen (y se pierde el original)
Lo intente con .png y .gif, y no tuve exito :'( puedes postear un ejemplo de como te quedan tus marcas
 

nk82

Nuevo usuario
Que raro... ¿puede ser que el problema esté en el PNG en sí? Es decir, que sea una revisión determinada del formato de archivos o que los que genera el Inkscape sean mas "standard" que los que generas tú.

Prueba con mi marca de agua a ver si tienes el mismo problema. Un saludo.

CondensadorFluzo.jpg

Watermark.png

CondensadorFluzo2.jpg
 

nk82

Nuevo usuario
Vaya, no me había fijado hasta ahora que me queda un sombreado blanco encima de la imagen... si al final el problema es el mismo pero con diferente color xD

Que putada mas gorda :(
 

spok01

Nuevo usuario
Pues yo de momento eh estado poniendo marca de agua de forma manual con el editor de imagenes, sin embargo seguire buscando una solucion con magento.

Saludos
 

screeege

Nuevo usuario
ALguien me podra aytudar yo habia hecho ya las marcas de agua en gif miden 50 x 600 pixeles, pero cuando lo pongo en magento en vez de poner una sola imagen y hacerla transparente solo me replica la marca de agua y no se ve la foto de atras (como si no estuviera transparente)

www.relojeria.com.mx

Gracias
 
Arriba