Métodos de envío

Xarlie

Super Moderador
Miembro del equipo
Me estoy volviendo loco para lo que quiero hacer y no termino de hacerlo bien.

Quiero tener la opción de envío gratuito si el pedido supera, por poner un ejemplo, los 100€. Esto no hay problema porque nos vamos a envío gratuito lo rellenamos y listo.

Pero el problema está en que no se que opción es la correcta para poner los gastos de envío si el precio es menos (una tabla de precios, vamos).

La tabla de tarifas nunca me aparece en las opciones de envío al finalizar la compra. Si pongo la tarifa plana siempre aparece, pero claro debería de desaparecer ya que el pedido ha superado los 100€ y es gratis el envío.

No hay una contribución que haga esto por lo que seguro que estoy haciendo mal algo :D
 

Xarlie

Super Moderador
Miembro del equipo
Si ya había probado lo del CSV, pero no me termina de funcionar... voy a probar con otras opciones y luego lo explico paso por paso para otros.

Muchas gracias!!
 

cbccharlie

Nuevo usuario
Haber, es muy fácil. Pero primero, antes de nada, que tipo de condición has elegido?
Peso vs destino, precioo vs destino o nº de artículos vs destino ? Porque los csv son distintos.
 

Xarlie

Super Moderador
Miembro del equipo
Vale, ya lo tengo... creo que metía mal el CSV porque después de unos cuantos errores ya me funciona. Explico los pasos seguidos por si a alguien le sirve:

Sistema > Configuración > Métodos de envío > Tabla de tarifas
Activamos, rellenamos los campos y seleccionamos (al menos en mi caso) Precio vs Destino, el precio es para toda España, pero se puede separar por diferentes campos.

Guardamos y ahora, en la parte superior izquierda, seleccionamos nuestra tienda de manera que nos aparecerá las opciones de CSV (exportar e importar).

Exportamos el CSV. Al abrirlo con Excel me aparece mal (por los ; del código HTML) por lo que yo lo he editado a mano con mi editor de texto, al tratarse de un CSV no hay ningún problema.

He puesto las siguiente líneas:
"País","Región/Estado","Código postal","Subtotal del pedido (and above)","Precio de envío"
"ES","*","*","0","5"
"ES","*","*","100","0"

Como veis elijo para toda españa de 0 a 100€ unos gastos de envío de 5€ y cuando lo supera pues 0€.

Importamos ahora el CSV (tablerates.csv) y ya lo tenemos activado.


cbccharlie, gracias por todo :D
 

zmeu

Nuevo usuario
hola a todos;

Yo me descargo el csv, introduzco las líneas e importo. Lo haga como lo haga siempre me dá el mismo error: "Invalid Table Rates File Format".

Utilizo el excel (igual que para importar los productos y no me ha dado ningún problema), lo he intentado tanto por peso como por precio vs destination y la única línea que introduzco es la siguiente:

"ES","*","*","5","15"


Espero que podaís ayudarme.

Gracias
 

zmeu

Nuevo usuario
Hola Tamagochi;

He visto una extensión de SEUR pero los precios me salen siempre a 0. ¿Sábes cómo se configura?.


Gracias
 

OSdave

Super Moderador
Miembro del equipo
la única línea que introduzco es la siguiente:

"ES","*","*","5","15"
me parece que no tienes que usar las comillas para los datos (sí para la linea de titulos)
 

zmeu

Nuevo usuario
Hola OSdave;

El archivo que tengo ahora mismo subido esta así:

"Country","Region/State","Zip/Postal Code","Weight (and above)","Shipping Price"
ESP,A Coruna,*,5.0000,15.0000
ESP,Alava,*,5.0000,15.0000
ESP,Albacete,*,5.0000,15.0000
ESP,Alicante,*,5.0000,15.0000
ESP,Almeria,*,5.0000,15.0000
ESP,Asturias,*,5.0000,15.0000
ESP,Avila,*,5.0000,15.0000
ESP,Badajoz,*,5.0000,15.0000

Hay que tener en cuenta que he cambiado en A Coruca por A Coruna en mi base de datos.

Gracias por tu ayuda
 

zmeu

Nuevo usuario
No no ese es el problema, que he probado de todas las formas posibles, he revisado varias veces cada proceso y todo parece correcto, pero después de introducir productos (incluido el peso) y elegir una de las zonas configuradas no me sale siquiera el table rate. Sin embargo activo cualquier otro modulo, como por ejemplo el de DHL y si me sale.
 

OSdave

Super Moderador
Miembro del equipo
pero vamos a hacer una cosa a la vez:
  • el mensaje de error de unvalid file format no te aparece, ¿verdad?
  • con que modulo trabajas, ¿el SEUR de defcon2 o el table rate de magento?
 

zmeu

Nuevo usuario
Es cierto perdona;

Estoy con el table rate, el mensaje de error ya no me sale (he descubierto que no se puede utilizar el excel y lo hago con el wordpad). Sube el archivo y me dice que está actualizada la información pero no me la aplica en el checkout.

Si activo cualquier otro modulo me sale el Título de ese módulo y el importe que corresponda pero no con el table rate.

Es un poco desconcertante porque cómo decía antes, lo he revisado varías veces y parece todo bien.

No se si influye en algo pero estoy con la versión 1.2.
 

OSdave

Super Moderador
Miembro del equipo
con lo que has puesto, solo haces envios a partir de 5kg.
Si el contenido de tu cesta no llega a 5kg no aparecera el metodo de envio. ¿Puede ser por eso?
 
Última edición:

zmeu

Nuevo usuario
Gracias Osdave, acabo de cambiar los 5 kgs por un 0 y ahora si me sale!!!!

Ahora viene la parte mala, jejejej, configurar toda la table rate.


De nuevo gracias por la rapidez y la ayuda ;)
 

Perutxa

Nuevo usuario
Hola Buenas a todos, he estado configurando la tabla de tarifas y lo he hecho exactamente como contaba Xarlie paso a paso (en table rate) y todo correcto, hasta que llego al chekeo de la mercancía y me aparece en el 4º paso "Método de envío" :

Disculpe, no hay presupuestos disponibles para este Pedido en este momento.

y lo he revisado y lo tengo correcto, habilitado, la tabla no me da ningún error, hasta he refrescado la cache que creo que no es necesario, haber si alguno me podéis echar una mano. Gracias.
 

OSdave

Super Moderador
Miembro del equipo
sera que algo en tu pedido no concuerda con la configuracion que has puesto. Puede ser la zona de envío, el peso o el precio, que no este activo en la vista de tienda...
¿como lo has confiugrado?
 

Perutxa

Nuevo usuario
Vale, ya he encontrado el fallo y me ha costado bastante;

Resulta que mi pagina al contrario de lo que yo pensaba esta en la website por defecto, no en la tienda que yo había creado hace un mes cuando empece con Magento, entonces guardaba los cambios en la tienda que yo cree, pero no hacia nada porque la que se me ve y donde estoy guardando todos los cambios es la de por defecto.

No se si me has entendido, porque en realidad no lo entiendo ni yo casi hahaha. pero bueno esta solucionado, muchas gracias por tu interes OSdave.:ok:
 
Arriba