No aparecen varios productos en el sitio que están en el catálogo

Rodrigo Palomo

Nuevo usuario
Buenas tardes, hay un problema en mi magento 2 y es que en mi sitio web no aparecen los productos que se tienen en el catálogo que está cargado en el admin de la plataforma de hecho en el catálogo del admin tienen el estatus de activo pero no aparecen en el sitio, lo que he notado es que si entro a algún producto que esta en esas condiciones y solo le doy clic en guardar ahora si aparece el producto pero como se puede hacer para que no sea un proceso manual ya que son muchos los productos.
Gracias
 

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Rodrigo,

Seguramente sea problema de la importación o del proceso de sincronización el cual ha creado los productos pero no los ha generado/guardado correctamente. Lo ideal sería que corrigieras ese proceso.
Si no pudieras realizar ese paso, puedes simplemente seleccionar varios productos en masa y pulsar en el desplegable de acciones que aparece arriba a la izquierda en la tabla de productos y pulsar sobre Update Attributes (Actualizar Atributos)
En la siguiente pantalla, simplemente pulsa sobre Guardar. Con este proceso estarás reproduciendo el mismo proceso manual que realizas tú, pero de forma masiva y una única vez.

Si tienes demasiados productos, sería recomendable que no seleccionaras todos a la vez, porque podría ser un proceso muy lento y acabar en error. De 500 en 500 debería funcionar bien si dispones de un buen servidor con los requisitos que recomienda Magento.

Un saludo.
 
Arriba