No soy capaz de ver magento en firefox

ososoft

Nuevo usuario
No soy capaz de ver magento en firefox. SOLUCIONADO

Buenas noches, estoy dando vueltas en los foros y no veo que le pase a nadie pero a mi si, me explico:

Instalo magento y lo veo bien en ie o en gnome pero en firefox se ve como si no reconociese la pagina en css !!.

Os dejo un link para que lo veais por si se os ocurre que es:

http://www.dieltron.com/mgn

gracias de antemano.

Saludos, Javi
PD. Lo he probado en 3 ordenadores !!
 
Última edición:

OSdave

Super Moderador
Miembro del equipo
de lo que veo, tus css tienen todo el código en una sola linea. Intenta subir otra vez las css originales de magento a ver si te lo soluciona.
 

Xarlie

Super Moderador
Miembro del equipo
Has comprobado con alguna de las múltiples extensiones de firefox que no tienes un error en algún CSS... puede que se te haya olvidado cerrar algo...
 

ososoft

Nuevo usuario
Ante todo daros las gracias a todos por ayudarme con esto, sobre todo a OSdave ya que soy un admirador suyo (de trabajo, me refiero :)) desde que leia sus post en qadram.
De verdad, gracias a gente como vosotros es por lo que funcionan estos foros.

Bueno al tema, estoy echo un lio:

valido la pagina en ccs3:
http://jigsaw.w3.org/css-validator/validator?uri=http://dieltron.com/mgn/
y me da un ok

Con el complemento "web developer" de firefox me indica lo siguiente:

La hoja de estilos http://www.dieltron.com/mgn/skin/frontend/default/default/css/reset.css no se ha cargado porque su tipo MIME, "text/html",no es "test/css"
La hoja de estilos http://www.dieltron.com/mgn/skin/frontend/default/default/css/menu.css no se ha cargado porque su tipo MIME, "text/html",no es "test/css"
La hoja de estilos http://www.dieltron.com/mgn/skin/frontend/default/default/css/clears.css no se ha cargado porque su tipo MIME, "text/html",no es "test/css"
La hoja de estilos http://www.dieltron.com/mgn/skin/frontend/default/default/css/print.css no se ha cargado porque su tipo MIME, "text/html",no es "test/css"
La hoja de estilos http://www.dieltron.com/mgn/skin/frontend/default/default/css/boxes.css no se ha cargado porque su tipo MIME, "text/html",no es "test/css"

El problema es que comparo mis css (que son los que me instala magento) y son iguales a las pagina de magento que estan corriendo por ahi y si las veo en firefox, solo se me ocurre pensar que es un fallo de mi servidor, pero el problema es que no se seguir, me pierdo un poco...

A alguien se le ocurre como puedo seguir ...

Muchas gracias !!
 
Última edición:

Xarlie

Super Moderador
Miembro del equipo
Te lo está interpretando como un HTML en lugar de un CSS... es posible que cuando haga la petición devuelva algo que le indique que es HTML ¿alguna cabecera del rewrite?

Pruebas a realizar:
Quita todos los XML y vete añadiendo de uno en uno
Prueba a añadir el código CSS directamente sobre el fichero header.phtml con sus tags de CSS
 

Xarlie

Super Moderador
Miembro del equipo
http://www.dieltron.com/mgn/skin/frontend/default/default/css/reset.css

GET /mgn/skin/frontend/default/default/css/reset.css HTTP/1.1
Host: www.dieltron.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Accept: text/css,*/*;q=0.1
Accept-Language: es-es,es;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://dieltron.com/mgn/
Cookie: frontend=4ad92e6b36b9ab707fcb6e2a38847104
Cache-Control: max-age=0

HTTP/1.x 200 OK
Date: Tue, 03 Mar 2009 00:34:57 GMT
Server: Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.5 with Suhosin-Patch
X-Powered-By: PHP/5.2.4-2ubuntu5.5
Content-Encoding: gzip
Vary: Accept-Encoding
Content-Length: 1137
Keep-Alive: timeout=15, max=99
Connection: Keep-Alive
Content-Type: text/html; charset=utf-8
Como puedes ver está recibiendo contenido de tipo text/html... ¿podría ser por el gzip? Quita el mod-gzip de tu apache
 

ososoft

Nuevo usuario
Muy bien Xarlie, gracias a tu aporte lo hemos arreglado.
Despues de hacer pruebas sobre el MIME de apache sin resultado vi en un foro que tambien se puede indicar en el .htaccess pero sin resultado y entonces miré el .htaccess de mi pagina principal y "VOILA" tenia puesto esto:
# Activa la compresion en el servidor
php_flag zlib.output_compression On
# Indica el nivel de compresion de 1 a 9 (de menor a mayor compresion)
php_value zlib.output_compression_level 5
# Indica sobre que extensiones se aplica la compresion
AddHandler application/x-httpd-php .css .js

Que lo puse para intentar aligerar la pagina (tengo un catalogo en css que me hace ir muy despacio sobre todo si navegan con IE6, en firefox no se aprecia)
Lo he quitado y ya se ve bien !!!!

Muchisimas gracias, ahora a seguir peleando con Magneto !!
 
Arriba