Pantalla Blanco de Admin

ManuelTC

Nuevo usuario
Hola he instalado Magento en Windows 10 sobre XAMPP pero no consigo entrar en la zona de Admin se queda la pantalla en blanco.

Mirando los logs veo en el debug:
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-ui/view/base/templates/logger.phtml' in module: 'Magento_Ui' block's name: 'logger' [] []
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-backend/view/adminhtml/templates/page/header.phtml' in module: 'Magento_Backend' block's name: 'logo' [] []
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-backend/view/adminhtml/templates/admin/login.phtml' in module: 'Magento_Backend' block's name: 'admin.login' [] []
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-backend/view/adminhtml/templates/page/copyright.phtml' in module: 'Magento_Backend' block's name: 'copyright' [] []


y en el de install :

[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-ui/view/base/templates/logger.phtml' in module: 'Magento_Ui' block's name: 'logger' [] []
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-backend/view/adminhtml/templates/page/header.phtml' in module: 'Magento_Backend' block's name: 'logo' [] []
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-backend/view/adminhtml/templates/admin/login.phtml' in module: 'Magento_Backend' block's name: 'admin.login' [] []
[2019-12-04 11:49:35] main.CRITICAL: Invalid template file: 'C:/xampp/htdocs/magento2/vendor/magento/module-backend/view/adminhtml/templates/page/copyright.phtml' in module: 'Magento_Backend' block's name: 'copyright' [] []


agradecería vuestra ayuda, he mirado en internet pero no consigo contactar.

Quedo atento.
 

Mikelgu

Miembro
Hola Manuel,

Para que funcione M2 en local con windows + XAMPP necesitas modificar el separador ya que Windows utiliza "/" y en cambio Magento utiliza "\".

Para arreglarlo puedes modificar el fichero
Magento\Framework\View\Element\Template\File\Validator

En la función isPathInDirectories
cambiar la linea del $realPath a

$realPath = str_replace('\\', '/', $this->fileDriver->getRealPath($path));

ya me contarás si te ha funcionado
 
Arriba