Pedido con IE no funcionan

Ksumiwue

Nuevo usuario
HOla de nuevo:

Me encuentro con algo gracioso, cuando intentas añadir un producto al carrito en la vista de galería o sección o familias, como queráis llamarlo en IE no deja hacerlo, no lo añade, da un error como que no puede, sin embargo con Mozilla si lo hace perfectamente.

Alguien sabe por qué puede ser.

La página es http://www.mistercebra.es

Gracias de antemano.
 

Ksumiwue

Nuevo usuario
HOla figura:

No sé por qué será, pero he probado en mi oficina con tres equipos y ninguno funciona. Uno tiene IE6 el otro IE7 y el último IE8.

Tienes algo en el navegador configurado que tenga que ver con javascripts o algo raro que nosotros no tenemos y el cliente tampoco y que a ti te deja hacer el proceso???

Gracias,
 

Xarlie

Super Moderador
Miembro del equipo
Cargador de Emergencia ha sido añadido correctamente al carro de la compra.

A mi también me funciona :)
(bonito diseño)
 

Ksumiwue

Nuevo usuario
Gracias por lo del diseño Xarlie. Pero no me consuela. Estoy un poco mosca, con este tema y con los "P..." navegadores, sobre todo con IE.

Es que no me lo explico. A vosotros os funciona sin problemas y a nosotros no y al cliente tampoco.

NO sé, voy a ver si miro en las tripas del IE y encuentro algo diferente.

Si podéis aportar algo será bien recibido.
Saludos y gracias,
 

Xarlie

Super Moderador
Miembro del equipo
Con el developer me aparece que al pulsar el botón de añadir se produce este error:

PHP:
Error: Permiso para obtener la propiedad Object.loadType denegado
Archivo de origen: http://www.mistercebra.com/index.php//regalos-romanticos/naughty-knot-lazo-regalo.html?SID=a18rmbus0q015ougrd7u8j1g42
Línea: 362
dentro de

HTML:
    <script type="text/javascript">
            var productAddToCartForm = new VarienForm('product_addtocart_form');
            productAddToCartForm.submit = function(){
                    if (this.validator.validate()) {
                            this.form.submit();
                    }
            }.bind(productAddToCartForm);
    </script>
Prueba a quitar lo de highslide porque quizás este dando errores o incompatibilidades con los javascript de Magento.
 

Ksumiwue

Nuevo usuario
Xarlie, me acabas de pillar en fuera de juego.

Juraría que he visto lo del highslide en algún lado, pero ahora mismo, no sé ni donde está ni donde lo he visto. Qué es???
 

Ksumiwue

Nuevo usuario
Perdón Xarlie

HOla de nuevo:

HA habido una confusión, creo. El error no se produce en la página de vista del producto. Que es donde me decías, Xarlie, lo de la highslide. Es en la página en la que ves los productos en grupos tipo grid o list.

Ej: cuando pulsas sobre cualquiera de las categorías del menu de la izquierda, te salen los "N", productos de esa categoría, es ahí donde no funciona el agregar al carrito con el IE.

Y no sabemos porqué???

Si a alguien se le enciende la luz, que nos ilumine por favor.

Gracias,
 

Xarlie

Super Moderador
Miembro del equipo
Ahhhhh! vale vale
Ahora si que no me funciona :)

Arrojo una posible idea: ¿has comprobado las cookies? ¿la sesión? Sobre todo con la caducidad de las horas por el servidor y el local. Esto pasaba en la admin en IE.
 

Ksumiwue

Nuevo usuario
Seguimos igual

He mirado las cookies, las sessions y no hay manera. He revisado los scripts que me estaban dando errores y ya no los dan. Esperaba haberlo solucionado, pero jaaaa! Seguimos igual.

NO se si cortarme las venas o dejármelas largas.

A alguien se le ocurre otra cosa???
 

Ksumiwue

Nuevo usuario
Si la tienda esta en local también. Tengo mi copia de seguridad y acabo de darme cuenta de que tampoco funciona el IE. NO me lo puedo creer.

Tiene que ser algo que hemos instalado, porque en las versiones anteriores, según he ido desarrollando la tienda, esto no ocurría.
 

Xarlie

Super Moderador
Miembro del equipo
Pues ya sabes, a ir desinstalando cosa por cosa.
También puedes ir eliminando zonas dela layout para que funciones las de default y ver si tiene que ver con algún bloque o algo...
 
Arriba