Problema con el plugin de Transbank Magento 2

Estimados, estoy intentando instalar el plugin de transbank para Magento 2 (módulo de pago) según estás indicaciones https://www.transbankdevelopers.cl/plugin/magento/#requisitos, la versión de Magento es la 2.3.4 y la de es PHP 7.2 y las versiones del plugin con las que he probado la instalación son la 3.3.0, 3.2.7 y 3.2.5. La instalación desde composer se completa sin ningún problema, no obstante al ingresar a la configuración del pugin Magento se cae y en el sytem.log muestra:
[2020-04-05 17:38:36] main.ERROR: Notice: Undefined index: tag_name in /home/cre56108/public_html/vendor/transbank/webpay-magento2/Model/HealthCheck.php on line 130 [] []
Este es el codigo de la línea 130 en HealthCheck.php

Error_HealthCheck_Line130.jpg

Los técnicos de Transbank insisten en que una opción podría ser bajar la versión de PHP a 7.1, al hacerlo se genera este error en la instalación:

Error_Instalacion_Plugin_PHP7.1.png

Por favor me confirman este concepto, la extensión está intentando instalar symfony/mime v5.0.2 y no es posible ya que necesita PHP 7.2
Si tienen alguna recomendación o pista para seguir sería maravilloso..., saludos
 
Última edición:

Toni FactoriaDigital

Experto en Magento de Factoría Digital
Miembro del equipo
Hola Rodrigo,

Será uno de los paquetes que requiere el módulo que intentas instalar.
Puedes pasar esa validación de composer mediante --ignore-platform-reqs, aunque en realidad, está ahí para evitar problemas de incompatibilidades.

Por si quisieras probar, prueba a lanzar el require así:

composer require transbank/webpay-magento2:3.2.5 --ignore-platform-reqs

Un saludo.
 
Arriba