Problema con la selección de idiomas

Tema en 'Soporte General' iniciado por ferche, 11/5/16.

  1. ferche

    ferche Miembro

    103
    1
    18
    Hola,
    tengo un problema con la selección de idiomas en la web http://www.nloop-store.com
    La web tiene instalados los idiomas Español, Inglés, Alemán y Francés. Al cambiar el idioma desde el frontend, sólo funciona correctamente para los idiomas Español e Inglés. Si seleccionas Alemán o Francés, sólo cambia el texto de las categorías, artículos, etc que estén traducidos, pero no cambian los menús de magento como son "Mi Cuenta, Mi carrito, etc"
    Existen las carpetas de traducción /app/locale/de_DE y /app/locale/fr_FR. También se la limpiado cache.

    ¿A que puede ser debido?

    Versión 1.9.2.2

    Gracias.
     
  2.  
    Comunidad Magento orgullosamente patrocinada por el hosting y vps magento de FactoriaDigital.com.
  3. Xarlie

    Xarlie Super Moderador Miembro del equipo

    2.715
    10
    38
    Aunque existan las carpetas con sus ficheros de traducción puede pasar lo siguiente:
    1.- Que la cadena no coincida con lo que está escrito, por ejemplo puedes tener "Mi cuenta" en tu fichero de traducción, pero en la plantilla se está llamando a "Mi Cuenta", al ser case sensitive no funciona.
    2.- En la plantilla no se está utilizando las traducciones, no todas las plantillas lo utilizan.
    3.- En la configuración de la tienda no se ha indicado la traducción correspondiente.
     
  4. ferche

    ferche Miembro

    103
    1
    18
    Gracias Xarlie,
    estoy utilizando la plantilla "modern". Lo curioso es que si por ejemplo en la configuración "Locale Options" selecciono como local "Alemán (Alemania)", entonces si que se visualizan todos los menús de Magento en "Alemán"

    problema-idiomas.jpg
     
  5. Xarlie

    Xarlie Super Moderador Miembro del equipo

    2.715
    10
    38
    Obviamente porque estás seleccionado para esa tienda el idioma alemán, o te refieres a que si lo cambias en global si que te funciona pero que a nivel de store_view no te cambia el idioma?
     
  6. ferche

    ferche Miembro

    103
    1
    18
    Gracias Xarlie,
    ya está solucionado. El idioma lo tenía asignado en el global, pero no en las vistas de cada idioma. No había caído en eso.
    Ya funciona!!
    Gracias
     
Cargando...

Compartir esta página

Cargando...