problemas para instalar

ivank

Nuevo usuario
Estoy intentando instalar magento en una cuenta que tengo en resellerzoom.com, pero no logro despegar...
Mi servidor me informa que las versiones instaladas son:
Apache : 2.2.8 (Unix)
PHP: 5.2.5
MySQL: 5.0.45-community
...lo que debería estar bien, pero sin embargo cuando corro la instalación, obtengo el siguiente mensaje de error:

Whoops, it looks like you have an invalid PHP version.
Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.
¿Alguna idea de qué puede estar ocurriendo?
Gracias y saludos,
ik
 

gmb

Super Moderador
Miembro del equipo
Es raro. El proveedor te ha dicho que tienes el php 5.2.5 o has hecho un phpinfo()?

Indica la versión de Magento, para ver si te podemos ayudar.

saludos.
 

ivank

Nuevo usuario
Acabo de hacer un phpinfo y veo que me han engañado con el Cpanel... la versión que está instalada es la 4.4.8...
Misterio develado.
Ahora les pregunto: es posible instalarlo con esa versión de php o necesariamente tendré que buscar otro hosting (o convencer a est agente que actualice su versión, cosa que lo veo difícil...)
 

AMateos

Nuevo usuario
Hola ivank,
Hasta donde puedo ver, si dispones de PHP5, sin embargo es posible que debas activarlo mediante .htaccess.

Prueba añadiendo la siguiente línea a tu archivo .htaccess:

Insertar CODE, HTML o PHP:
AddHandler application/x-httpd-php5 .php .php4 .php5 .php3 .phtml
 

ivank

Nuevo usuario
Hola AMateos!
Excelente tu consejo! Pude iniciar la instalación, pero al tercer paso, apareció el siguiente mensaje:

PHP Extension "pdo_mysql" must be loaded

Por lo que estoy viendo, hay que agregar una línea en el php.ini, pero la verdad que no sé cómo hacerlo en mi caso, ya que supongo que no voy a tener acceso a ese archivo...

En una ocasión solucioné un problema similar subiendo a la carpeta donde estaba trabajando un archivo llamado "php.ini" con un par de líneas que modificaban el archivo por defecto, pero en este caso no veo dónde subirlo... alguna sugerencia?
 

AMateos

Nuevo usuario
Hola de nuevo ivank,

Puedo contarte desde mi experiencia, ya que tuvimos el mismo error en nuestras pruebas y tuvimos que recompilar PHP con ese módulo para que funcionase la instalación.

Lo que no sé es si tu podrás hacerlo como reseller, intenta contactarles y a ver qué te dicen.

Un saludo!
 

jrgmayo

Nuevo usuario
Magento en Resellerzoom

Yo tube un problema similar al instalar magento en mi cuenta de reseller de resellerzoom, pregunte y me contestaron lo siguiente , y todo funciona bien...

Aqui la respuesta..

Hello, Php4 and php5 both the versions of php are available on our server. Your php scripts were being handled by php4 interpreter. I have added following line to .htaccess file in your public_html directory: ----------------

AddHandler application/x-httpd-php5 .php


Espero les sirva.. nos vemos
 
Arriba