tengo error en la instalacion, por favor ayuda

Tema en 'Foro de Errores' iniciado por Rodolfo, 13/11/08.

  1. Rodolfo

    Rodolfo Nuevo usuario

    6
    0
    0
    estaba viendo esta aplicacion y me ha gustado , estaba instalandola y en el proceso me salio un error:


    PHP Extension "pdo_mysql" must be loaded
    PHP Extension "mcrypt" must be loaded
    PHP Extension "curl" must be loaded

    desearia me ayudaran que puedo hacer, les agradecía un monton
     
  2.  
    Comunidad Magento orgullosamente patrocinada por el hosting y vps magento de FactoriaDigital.com.
  3. Xarlie

    Xarlie Super Moderador Miembro del equipo

    2.715
    10
    38
  4. Rodolfo

    Rodolfo Nuevo usuario

    6
    0
    0
    Gracias por tu ayuda , te comento que he leido sobre algunos errores y he hecholo que dicen pero me soigue saliendo el mismo error hay alguans cosas que no me coinciden como las ubicaiones de los archivvos como por ejemplo el php.ini no esta en la carpeta que mencionan tengo el servidor apache2.2 instalado bajo windows , si alguien tiene una mejor solucion le agraderia
     
  5. Xarlie

    Xarlie Super Moderador Miembro del equipo

    2.715
    10
    38
    La ubicación del php.ini es indiferente, puedes tenerlo en otro sitio.
    Para saber todo lo que necesitas de como está php create un fichero y pones esto:

    PHP:
    <?php phpinfo(); ?>
    Buscas la cadena "php.ini" y puedes ver donde tienes instalado el php.ini y funcionando, ese es el fichero que debes modificar.

    No olvides reiniciar el servidor apache cada vez que modifiques el fichero.
     
  6. Rodolfo

    Rodolfo Nuevo usuario

    6
    0
    0
    ya realize un cambio en el archivo php.ini ya lo pude ubicar y modifique las lineas que incluyen esos archivos:
    extension=php_pdo_mysql.dll
    extension=php_mcrypt.dll
    extension=php_curl.dll

    se elimino un error pero me sigue saliendo:

    PHP Extension "pdo_mysql" must be loaded
    PHP Extension "mcrypt" must be loaded

    no se que mas hacer
     
  7. OSdave

    OSdave Super Moderador Miembro del equipo

    2.136
    4
    36
    2 cosas:
    1. a veces hay varios php.ini, igual no has editado el bueno (si usas XAMPP)
    2. ¿has reiniciado el apache despues de hacer los cambios?
     
  8. Rodolfo

    Rodolfo Nuevo usuario

    6
    0
    0
    el archivo php.ini es el archivo principal porque desde el mismo menu del apache me sugiere que es el archivo de configuracion
    [​IMG]
    con respecto a xampp para que me sirbe
     
    Última edición: 17/11/08
  9. deFernando

    deFernando Nuevo usuario

    6
    0
    0
    Hola Rodolfo
    Veo que estás ejecutando el paquete AppServ, lamentablemente esa distrubución NO soporta la extensión PDO_MySQL requerida por Magento, o al menos no se si se puede instalar manualmente. En su lugar te recomiendo que uses xampp como lo recomienda la wiki de magento http://www.magentocommerce.com/wiki/general/installing_on_windows_with_xampp_and_wamp. BTW, xampp es lo mismo que AppServ (bueno casi).

    1. Descarga xampp para tu sistema windows. Te recomiendo la variación (7-zip) standar o la (7-zip) lite.
    2. Ejecuta el instalador y asegurate de instalar en la raiz de tu disco o partición ( C:\ )
    3. Edita el archivo c:\xampp\apache\bin\php.ini y asegurate de tener descomentadas las líneas:

      extension=php_curl.dll
      extension=php_hash.dll
      extension=php_mcrypt.dll
      extension=php_mysql.dll
      extension=php_mysqli.dll
      extension=php_pdo.dll
      extension=php_pdo_mysql.dll

      El resto déjalas como están.
    4. En la carpeta c:\xampp ejecuta setup_xampp.bat para iniciar los servicios.
    5. La carpeta por defecto o document-root es c:\xampp\htdocs donde tendrás que descomprimir Magento. Claro está que puede estar en otro lugar, pero tendrás que configurar apache para el cambio del document-root o directory para otros. (yo uso lighttpd)

    Espero que te sirva o te dé alguna idea.
    Saludos.
     
  10. Xarlie

    Xarlie Super Moderador Miembro del equipo

    2.715
    10
    38
    Yo también te recomiendo Xampp, pero cuidado, por defecto no está habilitada la opción de override y no podrás utilizar la reescritura de URLs de magento, por lo que siempre te saldrá con index.php.

    Para habilitar esto busca la cadena (dentro httpd.conf): AllowOverride None
    Y la pones con AllowOverride All
     
  11. Rodolfo

    Rodolfo Nuevo usuario

    6
    0
    0
    Gracias por sus comentarios lo instalare y probare para ver si puedo con xammp
     
  12. Rodolfo

    Rodolfo Nuevo usuario

    6
    0
    0
    Hola, gracias por su ayuda ya pude instalarlo , para ello tube que desinstalar appserver y de ahi instale el xampp , lo configure y descomente las lienas que mencionaron y todo bien, lo pude instalar , ahora el magento no viene con una base de datos de ejmplo como comenzar?
     
  13. OSdave

    OSdave Super Moderador Miembro del equipo

    2.136
    4
    36
    para tener categorias y productos de ejemplos tienes que bajar el zip desde la web de magento e instalaro (hacer correr el script sql) ANTES de instalar el software...
     
Cargando...

Compartir esta página

Cargando...