No funciona correctamente botón Añadir al carrito

Tema en 'Errores o fallos en Prestashop' iniciado por Alf_sm, 2/8/19.

Etiquetas:
  1. Alf_sm

    Alf_sm Aprendiz de Prestashop

    4
    0
    1
    Hola a todos
    Desde hace unos días cuando pulso el botón de añadir al carrito este aparentemente no hace nada. En el carrito no aparece entre paréntesis el número de productos que se quieren comprar salvo cuando si se refresca la pantalla o se pulsa cualquier enlace para ir a otra página.
    Al ir a la cesta de la compra es cuando se puede ver que todas las pulsaciones en el carro se han tenído en cuenta pero claro está, si se ha pulsado cuatro veces en añadir un producto al carro pensando que este no ha sido incluido en la cesta, ahora aparece el producto con la cantidad (4).
    Desde hace unos días he buscado información para resolver el problema en diversos sitios pero no encuentro nada que lo solucione.
    Agradezco mucho cualquier ayuda.
    Un saludo a todos.
     
    Última edición: 3/8/19
  2.  
    Comunidad Prestashop orgullosamente patrocinada por el hosting prestashop de FactoriaDigital.com con soporte en español.
  3. Josraso

    Josraso Lo cortes no quita lo valiente. Miembro del equipo

    739
    52
    28
    ¿antes te funcionaba bien? ¿has instalado algo? desinstala todo lo que hayas instalado antes, de todas formas deja la url de la tienda para que podamos ver.
     
  4. Alf_sm

    Alf_sm Aprendiz de Prestashop

    4
    0
    1
    Instalé varios módulos.
    Esta es la dirección: Tienda Hípica Chacón
    No tiene aún dominio a falta de terminar.
    Gracias por vuestro interés.
     
  5. Enrique FactoriaDigital

    Enrique FactoriaDigital Experto en Prestashop de FactoríaDigital Miembro del equipo

    103
    21
    18
    Hola Alf_sm

    Tienes que desintalar todos los módulos que has instalado porque el problema está en alguno de esos módulos.

    Saludos.
     
  6. Josraso

    Josraso Lo cortes no quita lo valiente. Miembro del equipo

    739
    52
    28
    Deberias empezar por desinstalar todos esos modulos que has instalado, alguno esta fastidiando el prestashop, he visto que tienes todos estes dando error:
    mpm_scrolltop
    blockproductinfo
    blockfacebookfooter
    mpm_header
    leftmenu
    empieza por desinstalar estes.
     
  7. Alf_sm

    Alf_sm Aprendiz de Prestashop

    4
    0
    1
    Ok, muchas gracias, voy a ello.
     
  8. Alf_sm

    Alf_sm Aprendiz de Prestashop

    4
    0
    1
    Por si os sirve esta pista que no entiendo dándole un poco al modo debug en la consola me aparece esto:

    Uncaught ReferenceError: scrollCompensate is not defined
    at HTMLDocument.<anonymous> (bottom-afc44333.js:277)
    at u (bottom-afc44333.js:39)
    at Object.fireWith [as resolveWith] (bottom-afc44333.js:39)
    at Function.ready (bottom-afc44333.js:39)
    at HTMLDocument.H (bottom-afc44333.js:39)
     
  9. Josraso

    Josraso Lo cortes no quita lo valiente. Miembro del equipo

    739
    52
    28
    Eso todo esta en la cache, trata de borrar la cache o bien con el botón desde la administración o bien manualmente, así a todo también activa el modo debug a ver si te dice algo mas.
     
  10. Salvita13

    Salvita13 Iniciado en Prestashop

    33
    1
    8
    Buenos días. Entro en tu web http://s786527718.mialojamiento.es/es/ y observo que...

    El modo debug debe estar puesto, hay varios errores entre ellos parece ser el módulo Whatsapp el que puede producir el error pero también hay errores que parece que tiene que ver con algo del pié de pagina de la plantilla.

    No desactives el modo debug aún, a ver si a algún compañero se le puede ocurrir con ese reporte de errores algo.

    Saludos.