[Solucionado] Bug en Override, Cart.php

Outlander

Amante de Prestashop
Declaration of Cart::updateQty() should be compatible with that of CartCore::updateQty() in /.../.../.../override/classes/Cart.php on line 156

Hola, por sorpresa y poniendo la tienda en modo debbug a cuenta de que no me envía la confirmación de la compra (Mailalerts) y que tengo bien configurado todo, me encuentro con este error que en principio no paraliza la tienda, pero ahí está dando guerra. Tengo claro que es un problema con un override de Cart.php, pero mi pregunta es:
¿Es un bug de la 1.6.0.9?
¿O simplemente es de algún problema netamente mío? ¿Alguna solución o idea de como atajar esto? Gracias.
Saludos
 

catoku

Amante de Prestashop
Re:Bug en Override, Cart.php

Outlander dijo:
Declaration of Cart::updateQty() should be compatible with that of CartCore::updateQty() in /.../.../.../override/classes/Cart.php on line 156

Hola, por sorpresa y poniendo la tienda en modo debbug a cuenta de que no me envía la confirmación de la compra (Mailalerts) y que tengo bien configurado todo, me encuentro con este error que en principio no paraliza la tienda, pero ahí está dando guerra. Tengo claro que es un problema con un override de Cart.php, pero mi pregunta es:
¿Es un bug de la 1.6.0.9?
¿O simplemente es de algún problema netamente mío? ¿Alguna solución o idea de como atajar esto? Gracias.
Saludos
Ese override se te ha tenido que instalar al instalar un modulo, quizas viendo el contenido puedas ver de que modulo procede... ya que por defecto no viene ningun override de clase o controlador creado o eso creo..

¿Conoces de que modulo proviene ese override? (Si no proviene de ninguno de los que tienes instalados en la actualidad, supongo que puedes borrarlo u renombrarlo...)
 

Outlander

Amante de Prestashop
Re:Bug en Override, Cart.php

catoku dijo:
Outlander dijo:
Declaration of Cart::updateQty() should be compatible with that of CartCore::updateQty() in /.../.../.../override/classes/Cart.php on line 156

Hola, por sorpresa y poniendo la tienda en modo debbug a cuenta de que no me envía la confirmación de la compra (Mailalerts) y que tengo bien configurado todo, me encuentro con este error que en principio no paraliza la tienda, pero ahí está dando guerra. Tengo claro que es un problema con un override de Cart.php, pero mi pregunta es:
¿Es un bug de la 1.6.0.9?
¿O simplemente es de algún problema netamente mío? ¿Alguna solución o idea de como atajar esto? Gracias.
Saludos
Ese override se te ha tenido que instalar al instalar un modulo, quizas viendo el contenido puedas ver de que modulo procede... ya que por defecto no viene ningun override de clase o controlador creado o eso creo..

¿Conoces de que modulo proviene ese override? (Si no proviene de ninguno de los que tienes instalados en la actualidad, supongo que puedes borrarlo u renombrarlo...)
No, que va. No tengo ni idea de donde ha procedido ese override. Ni ese ni esos dos que le acompañan:
Cart.php Attribute.php y Product.php

He mirado la instalación "a pelo" y como bien dices no vienen con la instalación limpia. Del los módulos del theme, tampoco. Pues la limpia tengo instalado en mi ordenador (con MAMP) con el Theme. Así que solo me queda pensar en algún módulo que haya instalado y desinstalado y haya dejado ese rastro ahí. O bien está instalado y ni se entera de que eso existe, porque los he renombrado (en vez de borrar) para hacer pruebas y el error no está y la tienda funciona bien.
Misterios en la oscuridad... :-o
Gracias por la info. Saludos.
 
Arriba