subida de archivo csv

areadigital

Aprendiz de Prestashop
Tengo un problema con la subida de imágenes en PS 1.6.0.14 , y no se como solucionarlo.

Los productos e imagenes me suben bien, excepto cuando la ruta de la imagen es con espacio. explico.

../gamablanca/aire acondicionado/imagen.png

aun que sustituya el espacio por %20 que seria:

../gamablanca/aire%20acondicionado/imagen.png

no me funciona.

he probado en varias tiendas con version PS diferente, y ningún problema, pero en 1.6.0.14 no hay forma.

mi problema es que el cliente sube los 3000 articulos 2 veces en semana.
alguien sabe una solución.

y el archivo viene del proveedor suyo tal cual con categorías etc....

He podido comprobar que funciona hasta la version 1.6.0.9
en las versiones posteriores ya no.
Yo tengo instalada la vesrsion 1.6.0.14 y volver hacia atras significa borrar todo y hacer una instalación nueva, meses de trabajo a la basura.

por favor si los expertos en PS, pueden hechar una mano. ya que este problema no me afectará solo a mi, si no a todos los que instalen cualquier version de prestashop futuras. a partir de la 1.6.0.9

un cordial saludo a todos
 

devoment

Experto en Prestashop
areadigital dijo:
Tengo un problema con la subida de imágenes en PS 1.6.0.14 , y no se como solucionarlo.

Los productos e imagenes me suben bien, excepto cuando la ruta de la imagen es con espacio. explico.

../gamablanca/aire acondicionado/imagen.png

aun que sustituya el espacio por %20 que seria:

../gamablanca/aire%20acondicionado/imagen.png

no me funciona.

he probado en varias tiendas con version PS diferente, y ningún problema, pero en 1.6.0.14 no hay forma.

mi problema es que el cliente sube los 3000 articulos 2 veces en semana.
alguien sabe una solución.

y el archivo viene del proveedor suyo tal cual con categorías etc....

He podido comprobar que funciona hasta la version 1.6.0.9
en las versiones posteriores ya no.
Yo tengo instalada la vesrsion 1.6.0.14 y volver hacia atras significa borrar todo y hacer una instalación nueva, meses de trabajo a la basura.

por favor si los expertos en PS, pueden hechar una mano. ya que este problema no me afectará solo a mi, si no a todos los que instalen cualquier version de prestashop futuras. a partir de la 1.6.0.9

un cordial saludo a todos
Hola,

Pero ¿Porque no le colocas un "guión bajo" depende un espacio al directorio?

¿Y estando en el mismo alojamiento con versiones anteriores te funciona sin problema? ¿O lo probastes en otro alojamiento?

En caso de que sea un bug, quizas ya lo hayan solucionado en el repositorio de github https://github.com/PrestaShop/PrestaShop
 

areadigital

Aprendiz de Prestashop
Respecto al guion, no puedo, ya que los archivos están ubicados en el servidor de la empresa que nos proporciona el csv y ellos pasan.

con otras versiones de PS anteriores, funciona sin problemas.
un saludo
 
Arriba